Bluetooth pairing not working in companion app - Android

The companion app on my phone has just stopped picking up any Bluetooth devices. It was working fine last week.

Location is enabled for the companion app. The phone can see the devices in Bluetooth settings. A connection is made between the companion app and the Apple TV app. I’ve restarted both devices and reinstalled the companion app.

Any ideas would be much appreciated. I notice the companion app updated on the phone yesterday, wondering if the update is the cause but no one else seems to have written about similar issues.

3 Likes

iPhone or Android?

A few things I check.

You mentioned the Companion app had updated. Make sure it has FULL permissions enabled and “remove unused permissions” is disabled. (that’s on Android)

Also make sure if you have a VPN or ad-blockers installed, the Companion app is exempted from any filtration.

Make sure EVERY device you own (phones, TVs, tablets, computers, whatever) have “forgotten” all of the devices you’re trying to connect via the Companion app. Basically, nothing should recognize that your trainer or any sensors you’re using exist at all - let the Companion app be the ONLY app that recognizes them.

Sometimes, other devices (BLE remotes, even media control buttons, selfie-stick buttons) will interfere with Companion connections. It’s worth shutting them all down while troubleshooting.

Some trainers have the option of disabling ANT+ radios in favour of BLE only - might be worth a shot if you aren’t using ANT+.

This may be relevant: Bluetooth improvements for controllable trainers & treadmills [January 2022] - #121 by shooj

1 Like

Thanks for the tips! I gave it a go but no joy.

I tried installing the companion app on an iphone and had the same issue, which made me think the problem was with the Zwift app on Apple TV so i reinstalled it but the issue remained.

It’s strange because the Zwift app can pick up the devices fine using the Apple TV Bluetooth, so i’m thinking the companion app can probably pick up the devices, but it won’t say they’re paired until it’s completed a handshake with the Zwift app, and that’s the part that’s going wrong somehow.

This sounds quite similar to what i’m experiencing, i’ll have a proper read through the thread now, thanks!

The whole thing isn’t necessarily relevant, it’s just that they’re definitely messing about with BT right now. :+1:

1 Like

Same here.
I’ve cleared the cache of the app (Android)
None of the devices was ever paired to anything else, or directly to my phone.
I depend on zwift companion as I run everything on Bluetooth. So at the moment my complete set up is useless…

Same issue here since Wednesday (everything was fine on Tuesday).

Did Zwift break something with an update?!

There seems to be another thread on the topic called “anyone-else-having-issues-with-bluetooth-through-companion-app-as-of-late”

I’ve tested Companion App 3.31.1 and can confirm that it works as intended. Would advise downgrading until the issue is resolved. You can find the Android version on Aptoid

I also reverted back to app version 3.31.1 and have been able to resume activities after two days of no connections.

The frustrating part is that other than the good people in here who have been posting about their issues and trying to help others troubleshoot and find solutions, I have seen zero acknowledgement from Zwift that there is even a problem. There has been the thread referenced above regarding the Bluetooth upgrades, but that hasn’t really addressed the issue that everyone has been dealing with as a result of those upgrades. According to Zwift, it’s “All Systems Operational”.

For the time being, we use the earlier version of the companion app until they decide to fix it. Thanks to everyone in here who has posted about their issues and to those who have assisted in finding a solution.

I can agree with you zwift does not give any explanation and I really do not understand why. Which is really sad of them. I can not believe that this problem can last so long. If this continues, I will consider disconnecting zwift

Having big connectivity problems using the Companion app Bluetooth bridge (Android) and Apple TV. Everything was working fine until the latest Companion app update (on Mo nday 28th Feb., I think).

Nearly screwed up my last WTRL-ZRL race when I lost the connection just before the start. Abandoned the Companion app and paired the trainer and HRM directly to Apple TV via Bluetooth no problem.

Just tried again (after clearing Bluetooth and Comapnion app caches and restarting Apple TV etc.) and managed about 45 mins of a free ride before another “Connection Failure” debacle. Getting well pi**ed off with this now.

Having same problem,worked Monday but no go since I installed the update.

Hello Matt, got the same issue… but i have no idea how to revert to 3.31.1 - can you maybe give me a hint how to get the old version back?

Thank you I figured it out and downloaded a version from a 3rd party site that seemed legit. This works. The new version is certainly broken and cost me the entire afternoon trying to fix this!

Glad you got it worked out. I actually found a decent site from another poster in these forums, so I can take no credit for the solution.

Again, frustrating that there hasn’t been more acknowledgement from Zwift that there is a problem.

indeed, i did everything - update android, update my Kickr - was already a bit confused because connecting to my Garmin still worked, and Wahoo app also was ok. Restart mobile, reinstall Zwift on PC, try Bluetooth dongle on PC, and did not realize the companion app just auto updated & nothing else was really wrong. Previous version and everything is back to normal… as long as Zwift does not reject connecions of the older companion release I guess.

Yes, could run Zwift on my mobile and then Stream via the Windows Phone connection to my big screen…but that is not really a nice solution with a mid-range phone :frowning:

Well have a good day and thanks :slight_smile: Could at least do still a shorty & go up alps & roast my legs

they claim it was fixed on 9th of march with latest companion update - did you eventually test yet?

I updated the companion app yesterday afternoon, and after a short ride, it looks like everything is working properly. I was able to connect all of my devices without issue.

Hope you have had success, as well. Cheers.