ANT+ Sensor Readings Get Stuck

Hi all,

For months now I’ve been battling an issue that spoils my rides, I’ve tried a number of things (detailed below) but I’m at a loss. I don’t know what the root of the problem is and I’ve been hesitant to drop thousands on a new computer/trainer. Please see below and if you have had a similar experience please let me know how you’ve dealt with it.

Issue: some time into a ride, typically at least 45 minutes in, my power & cadence sensor readings get stuck. It could be stuck at 90W or 455W, it could be stuck for seconds or 3-4 minutes. This makes group rides or races impossible. The issue happens out of nowhere and I’ve been very observant to try to find a trigger - I can’t. This happens intermittently during ERG mode workouts too, but the bigger issue is during group rides & races since I get dropped or fly away with stuck power readings.


  • Wahoo Kickr 2018 (purchased new in 2020) - this is the second to most recent model I believe
  • All firmware updates completed
  • Zwift up to date - I check for updates before every ride
  • Calibrated trainer via Wahoo app
  • Using ANT+, FE-C options for power/controllable/cadence from Kickr
  • Recently bought NEW Garmin Ant+ sensor & 3 foot USB cable that connects to my laptop - the ANT+ sensor is <1 foot from the Kickr
  • Only other sensor is Wahoo Tickr HR monitor (also ANT+)
  • HP EliteBook 850 G2 Intel Core i7, 16GB RAM (running Windows 10 Pro 64-bit)

Here’s what I’ve done:

  • Changed WiFi channels to 5GHz to avoid interference for ANT+
  • Turned off Bluetooth on the computer running Zwift AND nearby devices. I live in an apartment so I can’t rule out interference from neighbors. I’ve tested Zwifting at different times of the day and the issue is persistent.
  • Turned off WiFi from other devices / ensure other devices are off (work laptop, smart TV, xbox, etc.)
  • Turned OFF battery saver mode from the laptop and via Zwift menu
  • Disabled USB selective suspend setting on computer
  • Turned OFF Device Connection setting on my phone’s Zwift Companion app (this disables Zwift’ ability to connect via BLE through Zwift Companion)
  • Deleted knowndevices XML file in Zwift folder on PC to force new connections to be made

Using Zwiftalizer, I used to have 15%+ RxFail rates and after all the tweaks listed up there I’m hovering in the low teens but the sticky sensor reading issue still happens and it is driving me nuts. Attached are screenshots from Zwiftalizer for my most recent ride, the power & cadence readings got stuck in the last ~4-5 minutes of the ride.

Things I haven’t done:

  • Tested riding on only the Wahoo app. Since this happens unexpectedly sometimes after an hour of riding, riding aimlessly on the Wahoo app without Zwift is something I’ve avoided doing
  • Tried only Bluetooth - I used to have drop outs on Bluetooth using iPad so switched to this PC, which worked flawlessly until mid last year
  • Thrown my trainer out the window
  • New laptop or Apple TV (hard for me to get a TV set up for Zwift currently)

Hopefully I find a solution. Thanks for your help.

I had an issue where if the lights on my garage were turned on whilst i was Zwifting it disconnected my Ant+ devices.

I fitted a dedicated PCI USB card instead of using the in built USB ports and it sorted it. Try purchasing a powered USB hub. Cheap option but you just never know.

very interesting, thank you, i may as well try it! can you please share which model you got?

Libra a desktop computer so different setup. You need a powered hub, i could use a pci card.