Android Zwift not recognizing sensors

Hi,

Samsung S22, most current OS update, most current Zwift app update. New phone, doesn’t recognize my Garmim HRM and Footpod (both bluetooth and Ant+ enabled). I allowed location and unpaired all other devices in bluetooth settings, uninstalled/reinstalled Zwift, nothing worked. Both sensors had worked on previous phone, batteries are fresh.

I searched this category, can’t find anything current. Does anyone have any suggestions?

does the garmin app recognise the hrm?

1 Like

Two possibilities:

  • Make sure you have the ANT+ libraries installed on the phone. I’m doubtful this is the issue as you’re not seeing anything via ANT+ or BLE.

  • Strong suspicion: you still have another device or app attempting to steal control of the sensors. 99% of the time, this is the issue that leads to the symptoms you’re seeing.

See this very tongue in cheek thread: Pssst: Yes, you do have another device connected, dummy

1 Like

Thx for the responses, much appreciated! I’m still trying to figure it out. Here’s what I’ve done since the responses. Turned off computer that runs Zwift when I’m home, unplugged the ant+ dongles too. Deleted wahoo app from phone, removed the foot pod and HRM sensors, from my Garmin 945, turned the 945 off, checked Garmin connect app on my phone, no sensors connected to it, forced a stop of the connect app, installed the ant+ apps suggested, did a phone restart at each step, launched Zwift after restarts, still not finding the sensors. Never had any issues connecting sensors to Zwift phone app in the past so I’m really stumped here. I’ll keep trying, open to any advice.