Android | Companion app "network error"/ unable to log in [February 2024]

My default device for the CA is a Samsung Galaxy Note 10+. Until Marcello pointed out that mobile data works, I hadn’t been able to log into my CA in a week or so. I can now log in on mobile data, and use the app normally. However, when I switch to WiFi, it usually falls at or near the first hurdle, failing to show whatever ‘page’ you have asked it to. If I thrash around a few enquiries, nothing loads properly and the ‘Network Error’ will appear within one or two attempts.

FWIW, I also just tried a separate android device (Samsung Galaxy Tab S6 Lite) which doesn’t have mobile data and it works on WiFi with no issues, albeit I’ve only tried it for a few minutes. It doesn’t appear to be affected though.

Sorry I can’t provide more technical information. I’m not an IT expert.

Solution found :smile:
My WLAN-router had IPv6 deactivated => set IPv6 on router to “auto-detect”, then disconnected and reconnected WLAN on mobile, and my companion apps works again with WLAN!
(Further infos: In fact, my ISP does not provide IPv6. So I see now that with the setting “auto-detect”, the router uses “6to4 tunnel”, which seems to resolve the problem).
So happy I am back to Companion app. Hope this will resolve the problem for others too.

A big thank you to @Marcello_Gottardo for sharing this workaround method. I’m marking this as a solution to boost its visibility, but please comment to verify whether the issue is still affecting you or not.

If you would like to add any details regarding your ISP or IPv6 capabilities, this could help narrow down a common cause for the issue we’re seeing.

The network error pops up at a random point during activity for around 30 seconds before it reconnects and goes back to game options.

Ok, tried restarting my network, still have the error on my pixel 6 phone. Turn off the wifi and use the phones data the app works. Hopefully you’re able to fix the wifi issue soon.

I seem to only get it when viewing the events while riding.

it connects okay but if i go to the events page it gets the network error message

Mines stopped doing at. Rebooted my router and that seems to have helped.

Well, time is marching on with no proper resolution to this. Companion app only functional on mobile data, and not available ‘in game’. For the record, Marcello’s ‘workaround’ solution isn’t an option for me as my ISP doesn’t support IPv6. I’m a Virgin Media customer / victim in the UK and have a ‘Hub 3’ router. It does not have any of the options that Marcello was able to manipulate.

Any news from zwift HQ? This is annoing

when i open the CA (latest version, maybe the last two) I sometimes have to put in my login and password, or just click the back arrow a few times then i get logged in. Whether I have to do this or not, I always get network error when trying to see other riders signed up in an event. I do have IPV6 disabled on my entire network but this is not the problem. I downgraded my CA to version 3.54.0 and this solved the login credential passing issue and the seeing signed up riders in an event. (no more network error msg). so this issue was introduced in CA versions later than 3.54.0

1 Like

Sometimes entrant names come up first time on my Android Companion app, but usually for the last 2+ weeks I have to click network error “retry” 3-10 times to get it to work.