Companion app on Android not accepting login credentials

Anybody else having trouble logging into the Zwift companion app on Android? I’m not sure why, but the app suddenly started prompting for a password. It will not accept the current password. I get an i invalid username/password message every time. I tried changing the password - no change. Reinstalled the app no change. The app did this once before, a couple of weeks ago, but I restarted the app and it worked without asking for a password. Not this time.

Possibly this issue. Try disabling WiFi and logging in.

Wth? I wasn’t getting a network error message, but when I switched to another wireless access point in my house the app didn’t ask for a password and just working as usual.

Oh, looks like the wireless network selection was the problem. While all of the devices in my house share one network, I have several access points and use both 2GHz and 5GHz bands depending on device capabilities. My phone and laptop running Zwift were not connected to the same access point. Perhaps the companion app is using broadcast messages to locate a host running Zwift? If so, then those packets might not be reaching the other device.

1 Like

I’m not sure why that would cause a login problem with Companion, but it certainly could cause it to fail to connect to the game once logged in.