Android 14 / Samsung Dex

Yesterday I updated my phone (Samsung Galaxy S21) to the new android version (Android 14).
And now when I start Zwift in the full screen modus with the Samsung Dex app, it looks like the game starts in a wrong screen resolution
I never had this problem before.
I contacted Samsung, but they say that Zwift is probably not up to date is with Android 14.

2 Likes

Zwift works with Android 14 on my Pixel. I suspect it’s something to do with Dex. Have you tried disabling Dex to see if Zwift runs in your expected resolution?

Zwift works fine when using it on my phone. Even when the screen is minimalised (on my tv by while using Dex) it looks fine. But when I go to full screen modus… wrong resolution

I have the same problem. Got round it by just screen sharing instead of using Dex. Unfortunately nothing gets tested on Dex :(.

Same thing happening to me.
Also not possible to do a spindown anymore.

When using laptop also no spindown possible but maximizer screen on monitor works well

Which trainer? If it’s a Zwift Hub, they auto-calibrate. If it’s anything else, never use Zwift to calibrate it. Use the manufacturer’s app.

I use a Kickr Core.
Up till last week spindown via Zwift worked fine .

If i start it now it firdt shows a very high speed and states I should stop pedalling. Then speed goes to 0 (zero) and nothing happens anymore. Only cancel button works.

I now and then dit it via Wahoo app but using that on same phone where zwift is on did make Zwift work incorrectly. So I use the spindown in Zwift only since more than a year.

When spindown doesn’t work in Zwift, the first thing you do is go straight to the Wahoo app and do it there. If that fails you talk to Wahoo. Doing the spindown in the Wahoo app also gives you an opportunity to update the trainer firmware. The Wahoo app should not affect Zwift as long as you unpair the trainer from the Wahoo app or terminate the Wahoo app.

Thanks Paul for the response(s) but this does not make clear to me why it worked until last week and now doesn’t anymore.

Note: spindown in Wahoo app is now and then also not working. Having discussions with Wahoo servidesk already on that. Was an extra reason to do it via Zwift for me.

Could it be that Zwift supports auto calibration for the kicker core?
When I look in the Zwift shop, I see they’re selling the kicker core on this moment.

I’ll hope they fix the full screen problem (while using dex) soon!!

I don’t think the current Kickr Core firmware can do autocalibration at all, but it usually doesn’t need to be calibrated frequently. Once a month is probably enough.

If this feature gets completely broken I expect there will be a lot more reports about it. AFAIK you are the first.

Just installed the new game update… it didn’t fixed that issue :expressionless:

If it’s not an issue with the game (completely unclear at this point) then no update will solve it. Once you can reliably calibrate with the Wahoo app then you’ll have a clearer sign it’s a Zwift problem. Until then it’s impossible to say. Since there are many people using the Kickr Core perhaps you’ll get confirmation if it’s widely reported.

I’m talking about the wrong screen resolution while using Samsung Dex.

I’ve been having the same problem for a couple of weeks since the big phone update. The problem is with the app, not the trainer (I have Direto). I will report it to Zwift

I have the same issue, my Samsung tablet updated to Android 14/Samsung one ui 6.0 and now the external full screen option using Dex doesn’t display correctly. I was able to use the zwift app with standard screen mirroring but the graphics are not as good. I tried a different app that worked fine on the second screen so I am confident its an issue for zwift to resolve. I have reported it.

This is a reaction i got from them…

Ok, I understand. However, Zwift is not specifically designed to be used in this way and therefore it will be difficult to identify and resolve the issue. Have you tried removing the Zwift app, rebooting thew phone and then reinstalling the Zwift app? This may refresh the installation and resolve the issue.

Zwift Ambassador - Community Support

I got still hope they’ll fix the problem :pray:

A Zwift ambassador is a more or less random user they appointed to the role of providing tech support for almost no pay. It’s not what I would consider an official company response. You might try asking them to escalate the problem to Zwift support.

Hi

I had same problem, but could by-pass it in samsung setups: advanced features > labs > multi window for all apps. After that Zwift opened directly full screen mode and resolution was good.

6 Likes

Whoop whoop!!! You’re my hero for today :partying_face: