After 1.51 update steering with Zwift Play is laggy

I have a Kickr Bike 1.0 and Zwift Play and Windows 11. Even though not intended it was possible to have Kickr Bike AND Zwift Play connected as steering devices at the same time before update 1.51 and it worked well for me.

As I understand, update 1.51 brought the intended co-use of both steering devices. Unfortunately it does not work properly. If I use both devices as usual they show an odd behaviour now. At first they both are very laggy, after a while the avatar just moves fast to one side and after that none of the steering devices works anymore. A minute or so later they start to work again and everything starts from the beginning (laggy, side, stop working, repeat). Zwift Play is connected the whole time (buttons are working).

For my last ride I disconnected Kickr Bike steering to see if Zwift Play works properly when used alone. The Zwift Play steering was so laggy the whole time that it is barely usable as steering device. Takes more than a second to respond at all and than it moves the avatar hectically all over the street. Much different to the good steering experience I was used to before the update.

Does anyone else experience the same?

Strange, but yesterday everything worked fine again. :slight_smile: