Access Denied when Downloading Zip of .fit files from ZwiftPower (BUG)

Earlier today I attempted to compile my fit files from Zwift to download from the Activities tab in ZwiftPower. I get the notification that the zip file has been created. When I click the link that was e-mailed and the click the button to download the archive on ZwiftPower, I get an error message ‘access denied’. I am able to download individual .fit files, but I have quite a few and it would save a lot of time by downloading a Zip file. I haven’t started the research yet, but I think other than downloading files, I would look for an API to connect to ZwiftPower to grab the data, is that possible?

-ZB

Hi @Zwift_Beats

Welcome to the forum.

If you are using Pc you can find all your fit files in the documents directory.

https://support.zwift.com/en_us/your-history-and-fit-files-SJbHywdNH

1 Like

Thanks! Unfortunately I am using an Apple TV for my setup. I read that there is an option to email the files in the app that I thought I would try. It’s really about the initial data export, keeping track of rides after I wouldn’t mind downloading my individual rides. Out of curiosity, would a fresh install of the app, ‘download’ the ride history as well? If it did, I would just install on my device I am doing my data work on to grab those files when needed.

No a fresh install won’t work, you will loose all the files.

You can link Strava to Zwift and all your activities will be available in Strava.

Out of curiosity what do you use the fit files for.

EDIT:

If you get that link in the E-mail, right click on it and select save link as that will save the Zip file.

image

Or you can right click in Zwift power and save link as:

image

**IGNORE ALL THE EDIT ABOVE: It does not work. :scream: :flushed: :tired_face:

Got It, I kind of figured the ride history was being stored locally. One of my roles for day work involves data analysis/creating dashboards/machine learning (So I am a data nerd, everything is data :D) I want to be able to chart my ride data along with other data that I might have available that is relevant (ie. daily calorie intake, multiple weight-ins., food diary, etc.). I also want to be able to use that data to assist in planning my upcoming rides. I’ve already have methods for incorporating that data into the ride data (I did a test a few months ago before I knew about ZwiftPower). I created an API to grab my Strava data, unfortunately when I tested it was only returning the previous 30 activities. I hadn’t had the opportunity to see if I can fix that, but once I learned about ZwiftPower, I thought that would save some steps, eliminating the need for an API.

You have my attention :slight_smile:

I have been tracking all my data for over 15 years. Yes manually entering everything in Excel.

I use golden cheetah it sync to Strava and my smart scale and you can create python and R-script panels to view your data.

I would think you can bulk download your data from Strava and then you only need daily updates so the 30 will be good.

Wow! Excel by hand for 15 years (whew). I’ve been experimenting with Microsoft/Office 365 as a whole, there are some nice tools available to create UI (Power Apps) to drop in data so it doesn’t feel like a chore. I would technically then have ability send myself notifications to enter my supplemental info once it knew I completed a ride. I will check out Cheetah in my research. I created a script in Postman to fetch the data. At the early stage I was going to do all of my translations right in Power BI, until I knew what specific data I wanted, then do the work in Python to automate retrieval and computation. It was quite odd that Strava was only returning the last 30 activities. I thought I would be able to bulk download, but not the way I thought. I couldn’t find any documentation on the Strava API that indicated it would limit the return. I don’t have a lot of pre-Zwift data in Strava, but I thought it would nice to see how far I’ve come since those days. I just got a new smart scale this week which reinvigorated my interest in doing this exercise.

BTW, when right clicking the link and ‘Save File As…’ from a Windows 10 PC failed as well. It seems to be a malformed hostname. ‘Edge notes the hostname couldn’t be found’ when I check the error created. When I get a moment I will see if I can figure out if it is typo I can correct.

1 Like

I only did it by hand until cycling computers and watches got the function to download data. I don’t miss the days of manually typing everything into excel.

Yes I realized that the file is broken once you do the save file as.

It sound that you tried all that I tried already.