Absurd Zwift hub connection problem - is my old phone keeping the Hub captive?

I’ve had the Zwift Hub since it came out. Always had lots of connection issues, drops, and no consistent best way to get it to run. Sometimes I’d run it on my phone in the Zwift app, sometimes on my laptop via the companion app.

I’d recently let the Hub sit for a few weeks with no activity, in part because I managed to drown my phone so much with my salty sweat that it would not display anything unless I squeezed the front screen display and the back panel of the phone together with my fingers.

Yesterday I wanted to do a ride. Updated Zwift on my PC and wanted to see if I could just connect via my laptop’s own bluetooth connection (has never worked). No, didn’t work. I squeezed my phone together will all my strength and got into the companion app. The app shows the firmware on the Hub needed to be updated. It did not want to do so. “Updated failed” and “Connection failed” and “Only connect one device at a time” messages again and again, per default. I still don’t believe I was doing anything wrong. Eventually the Hub showed up on my laptop screen showing the “no signal” error. It mentioned that a firmware update was available. Sure, great. I tried to get it to update in various ways in the companion app with no luck until I could not wrangle my phone together with my fingers anymore and I gave up.

Today I bought a new phone (Oneplus Nord 2T - does Bluetooth versions matter?) and figured I could finally set it all up. No, absolutely not. Hub wakes up when connected to power chord, seemingly goes into pairing mode but nothing turns up in the companion app on my new phone. Tried downloading the Zwift app on the new phone as well, nothing shows up. Updates, reinstalls, nothing. My laptop was switched off, battery in old phone off, nothing else it could be connected to. And it was blinking blue. Nothing.

I tried various orders of doing things - first powering up the hub, then opening the companion app, then the zwift app on my laptop, or any order of those. Nothing.

Then, to my surprise, when I decided to power on my old phone, it was still showing the update available in the companion app on that phone. And for some reason,all of a sudden the Hub looked as though it was paired (no more blinking) and it showed up on my laptop. First with no signal, but all of a sudden working. My laptop was set to pair via bluetooth (which, again, has never worked for me), not via the companion app. Utterly bizarre. Still couldn’t update the firmware.

So, as absurd as it sounds, it looks like my old phone is “keeping the Zwift Hub captive”, even when the phone isn’t even on and although the Hub is still here blinking at me like a blueeyed cyclops from ****. Factory reset? Try the companion app, right? F… annoying.

I figured my old phone might release my hostage Hub if I deleted the companion and Zwift app. Nope, didn’t work. All the while, my technique of squeezing the front screen and back panel together on that old phone is turning my fingers into acid and I’m getting desperate. After uninstalling and reinstalling the companion app and still seeing the message in the main feed that a firmware update was available, I finally managed to squeeze the phone so hard that I made that whole problem worse. Basically the phone is inaccessible now, the screen is dead.

So, now I have a hostage Zwift hub on a phone that no longer works - i.e. I threw away the key. I even signed up for Rouvy - didn’t find the Hub.

I’ve obviously looked through all the generic guides (yes, I made sure the Hub isn’t connected elsewhere, yes I tried to limit the amount of bluetooth action going on in the room, yes, I’ve tried to update this and that) and it seems there’s nothing out there. If nothing else, I guess it could be a cautionary tale for those considering whether to buy the Zwift Hub.

How do I fix this problem? How do I even reach customer support?!?!

Hi @T_hor

Welcome to the forum.

This sound like you are not having fun, sorry for that.

Bluetooth is a pain, it can only pair with one device at a time and it sound like it is paired to your old phone. (Never attempt a firmware update on a phone that has issues or that have little battery left)

I would assume there is a way to hard reset the Zwift hub. Turning off and unplugging the Hub for some time should release the bluetooth and set the hub in Advertising mode.

Hi @Gerrie_Delport_ODZ

I have other devices running on Bluetooth that can manage being paired with multiple devices. And I’ve never had a piece of technology effectively held captive by another this way.

I’ve obviously tried to switch the Hub off and on - as stated pretty clearly. After doing so, the Hub blinks as though it’s gone into pairing mode - as stated - and yet it does not show up on any of my devices.

I don’t really consider switching something off and on a hard reset either - I was thinking a factory reset.

And to your point about what to never do - I did not attempt to do the firmware update. As I stated, I opened the companion app after a while, already buggy, and it did not allow me to even attempt the update.

Edit: say the scenario was that I hadn’t used my Hub for awhile as in the above but my phone had been stolen. Same technical problem, essentially. Who’d be to blame?

1 Like

Does Zwift support even exist? Are there actual human beings employed or just unpaid “ambassadors”?

Does Zwift support even exist? Are there actual human beings employed or just unpaid “ambassadors”? Is there a number that one can call (in EU) or no?

This doesn’t answer your question but I believe the ambassadors do get paid for every question that they answer.

ambassadors can escalate tickers if required to higher level support.

What is the problem if you are open to share you can quite often get good support from other zwifters and some zhq staff look at the forums.

I can neither confirm nor deny whether or not I am human.


@James_Zwift , I suspect you’re a pace partner in diguise :rofl: :rofl: :+1:

I thought the new look for the RPs was based on what James looks like in real life …

1 Like

I have to say they were first class, got a replacement trainer within days, its up and running.
Great service.

Oh I’m very open to share. Basically my phone broke and now my Zwift Hub can never be disconnected from that in order to connect to a new phone. So I may as well throw it in the garbage. I’d like the issue to be fixed or to return the product under warranty if Zwift cannot fix it.

I’ll see if I can get someone to contact you (it’ll be electronically).

Please refrain from hitting it with your hammer.

Thank you for understanding my frustration and for making me feel like a valued customer. Could you add a few more details on how such a process would look like?

Okay, that’s fantastic to hear. Thanks for sharing. Happy for you.

@James_Zwift how did it go? Would you like for me to share my contact details or is that available through my user here?

Am i missing something or could you just not take your phone that is broken far far away so bluetooth is out of range and then turn the zwift hb off and back on again and then connect it to the new device? or just wait for the battery to die in the old phone

You have an open ticket that I asked someone to reply to. Sorry they haven’t, I’ll try chasing it again today.

A suggestion I was given was that you go to your Documents/Zwift folder and delete the knowndevices.xml fiule and try again on the new phone.

Hello James
I am currently having the exact same issue as T_hor. I have been working with an ambassador for the last couple days and have yet to have my hub connect successfully. I was on vacation for a week and returned to use but was required to update on both companion and Apple TV app. I did and no longer able to connect. I’ve tried everything previously mentioned but still not working. Where do I go to delete the xml on my phone or Apple TV?