Able to login to but nothing there ("Looks like you're lost") and fit file of last ride corrupt


Yesterday I finished a regular ride (not with a bot or anything), and the ride was saved properly in the companion app with all ride data there. However, when logging into my zwift dot com, I always get the page:

We can’t seem to find the page that you are
looking for. Here are some helpful links instead:

This continued this morning. Tried it on several devices, with several browsers.
When trying to upload my .fit file (on my Mac, found in Documents-zwift-activities) to strava, the file seems corrupt

Anyone experienced the same?

Thanks for the help!

The “my.zwift” site has had availability issues recently so perhaps that is back. Keep trying.

The corrupt fit file, depending on what caused it and how bad it is, can be fixed and uploaded via

Zwift has had quite a few issues around recording rides including some similar to yours so fingers x’ed, its not a recurring issue for you.

1 Like

Indeed, kept trying and by the evening of the next day, the issue was solved!

1 Like