2 Zwift Plays One Windows desktop

I just purchased a second Z Play for my training bike. My wife’s bike already has one. We both use the same Windows 10 computer that was built just for Zwift. We have separate accounts and use the computer one at a time. Her setup works fine. I can’t get the new set of controllers to pair on Bluetooth to the desktop. They don’t show up when searching. They will pair very unreliably through my iPhone as a bridge to the game. Their software is current. The desktop reviver is Intel 5.1.
Is it that the linked device file in Zwift will only allow one set of Zwift Play?
The second set of controllers are unusable as is.
I need HELP

I suspect this is your issue, don’t pair them to the desktop, let Zwift find them after launching the game.

Maybe I stated this wrong. I am waiting for Zwift to find them and then hit OK. I am not pairing them. But Zwift has yet to find the new controllers on the desktop

are you selecting the “search” option when in the pairing menu? I assume the controllers are powered on as well and the Z button is lighting up.

Mike, I have one system that works. and a new one that doesn’t. All setup is done correctly. Zwift can’t find the new controllers. The battery is charged the software is updated and they are powered on prior to pairing screen. They just are never found on the desktop. if I chose to pair Bluetooth through my I phone as a bridge they are found and connected. But they drop out continually during the ride.

Perhaps you got a bad pair of controllers? I suggest contacting Zwift support.

Thanks for trying Mike

1 Like

Andi from Zwift HQ here! We worked with @bikeboy via email and they confirmed that Zwift version 1.46 solved this issue. Thank you all!

1 Like