Zwift App on Windows 10 PC + ZC on iPhone = no stats on ZC + solo ride

Hello all:

I’m less than a few months into Zwift. I’m really enjoying it. I’ve run into one thing which may be a known issue…

I have contacted tech support at Zwift, but I’m not sure they know what’s causing this issue, so I thought I’d also reach out on the Forums in case somebody else has experienced this.

I typically run the Zwift app on my Mac or on my PC (running Windows 10), depending on which one is available in my house at the time - unfortunately even though I prefer the Mac, it’s not always available. I run Zwift companion on my iPhone which is mounted on my bike where the bike computer usually sits for IRL rides. My Mac / PC are connected to a flat screen TV by an HDMI cable so I can see what’s going on on a bigger screen.

Not that this figures into the issue at all, but everything (Mac / PC / iPhone / flat screen TV) is connected to a common Wifi network on a router in the room that is dedicated / exclusively used for Zwift rides. And, I use a Magene T300 smart trainer, fwiw.

Everything works perfectly with the Mac + iPhone combo. I can see the game field on the Mac and on the flat screen, and I can use Zwift companion to check the map, give ride-ons, or whatever else.

Things don’t work so well with the PC + iPhone combination. When I start a ride or a workout there are no other riders “out there” even though I have no network connection issues and I can see, on the map (both on the game and on the companion app) where I am. If I start a pace partner ride, again, I’m “out there” solo. When I start to ride I can see my speed / cadence / HR / power on the game screen (PC and flat screen), but on the companion app all those fields are empty.

Zwift tech support is saying that it’s an issue with which ports are open on my router… but I’m skeptical about that explanation because the Mac + iPhone combo works flawlessly. It makes no sense to me that my router would only cause problems when the game is running on my PC.

They have also suggested that I reinstall the Zwift app on my PC, which I have done. The problem still exists.

Any hints, suggestions, sharing of similar experience would be appreciated. This could very well be two different issues.

I’ve attached some screen caps of the Zwift app (on my PC) and the companion (from my iPhone) in case this would help.

2 Photos of Zwift game view running on PC (can see stats in upper left box, but you will also notice that there are no other riders around, even if I’m trying to do a pace partner ride…):


Screenshot of map view on ZC from my iPhone when Zwift app is running on PC (notice no cadence / power / HR / etc stats):

Screenshot of dashboard on ZC from my iPhone when Zwift app is running on PC:

Screenshot of workout dashboard on ZC from my iPhone when Zwift app is running on PC (I see the internal I’m on and what intervals are coming up, but no cadence / HR / wattage stats):

You’re not running a VPN on the PC, are you?

1 Like

good question @Steve_Hammatt . something i also thought about… especially since VPNs are quite common here in china.

to answer your question: sometimes yes, sometimes no. i have tried it on the PC with / without VPN it’s the same.

the router is running VPN (which i can disable), so the Mac would be affected in the same way, presumably. but it isn’t.

What firewall software is running on the PC?

As you say, it’s unlikely to be your router if your Mac is fine, but it does sound like some sort of port-blocking issue,. probably on the PC itself.

1 Like

Good point… I’m running McAfee. I’ll see if that’s what’s causing the issue. Thanks.