Zwift won’t load

Anyone else having issues logging into Zwift?

I’ve been stuck on the Zwift login screen for about 15 minutes this morning trying to get into the game. Zwift having none of it!

I suspect their system is down?

I just tried logging in, works fine. Maybe could it be a problem with your internet? In the past whenever my internet was weak it did not load. Also maybe try restarting your computer - has fixed the issue in the past for me.

1 Like

Same here. Unable to access Zwift or Companion app having tried on 3 devices.

1 Like

There’s about 7,500 people on Zwift right now, and I’ve just been riding myself.

So whatever problem you’re seeing isn’t affecting everyone. Might just be something you can keep retrying and then get in?

1 Like

I have similar issues for about 2 weeks now

1 Like

Thanks Steve, this is reassuring- perhaps a local network issue, I’m not sure.

Sorry to hear this Jon , did you find any fix?

This is the same for me SJ - issues across all devices

Thanks Roman, the old turn off turn on trick hasn’t work for me this time, having the same issues across multiple devices - suspect your right about poor WiFi signal though!

Could be some sort of firewall issue, or erroneous blocking by your ISP. Try using a mobile hotspot to see if you can get in.

I had trouble logging in for about an hour at 8.30am BST, and Zwift Companion repeatedly told me there was a network error. When I did manage to get in, the home screen showed no other riders in any world. Went into Watopia and other riders did show up, but they were almost all called N VALID, and I was unable to move, so I just gave up. Had no Internet problems otherwise, as far as I could tell. Zwift was working fine again by midday.