Zwift - Uploading runs from training peaks

Hi

I am struggling to get my planned runs from training peaks to zwift. I have tried everything with my running coach to fix this but to no avail. I have disconnected and reconnected, changed the run format, tried to add the FIT file to my zwift workout folder on my laptop but still won’t work. I appreciate the run only shows up on the day it is set.

Has anyone else had the same issue? any advice?

Thanks
Becky

I think the main issue people encounter is when the TP workout is set by time intervals i.e. 8 minute warm up, 1 minute full pace, etc. I ensure my TP run workouts are distanced based [2k warm up, 800m *5 etc] and it seems to work pretty seamlessly. Hopefully that might help? They appear under Workouts menu in their own Custom Workout folder on the relevant day…

Matt

Thank you for the reply. I think that is the key and that has helped.

Thanks

No probs. Good luck with the training!

Although from my understanding time/pace based workouts now work for running - they only work for Zwift created workouts - not for ones sent from TrainingPeaks.

I can only get them working if as Matthew mentions is to setup the intervals are distance based.

Its very annoying also we can’t do power based runs yet either…

If you don’t mind the work, you can create the time based workouts with https://www.zwiftworkout.com/editor/

I did that for my 80/20 plan. But it’s easier to do it directly in an (text)editor once you have the necessary Format from the file the site created.