Trainingpeak workout running wont show up in Zwift

Bike workouts work just fine.

Anyone know how to solv it?

/Christian

Hi Christian,

The following works for me (assuming your Training Peaks and Zwift accounts are already linked if it works for bike rides):

  • Create a Training Peaks workout.
  • Select ‘Run’ for ‘Add Workout’.
  • Click ‘Build workout’ and use the following settings: Distance, % Threshold Pace, Target
  • Build workout with blocks, but ONLY use % Threshold Pace in the workout details editor
  • Name the workout
  • Schedule the workout on a future day in your TP calendar.
  • Login to Zwift on the scheduled day and the workout appears under ‘Workouts’ and ‘Training Peaks’ categories.

Hope that helps - Cheers, Alan

Big thx!
Works like a charm=)

/C