Zwift upload to Garmin Connect Issues due to FIT file timestamp1989

Automatic syncing has worked fine for me for ages, but recently it has failed. I went through all the disconnect/reconnect options and still no joy. Aftersome investigating I found the following:

  1. Recent Zwift FIT files will not even manually upload to Garmin Connect (GC).
  2. The files are failing a GC check due to the “local-timestamp” being set to 31/12/1989 and the “timestamp” having the correct date (I think Garmin see the dates as too far apart). It looks like this is what is stopping the automatic sync as well as the manual uploads working. Oh and yes, my device has the right time set locally.
  3. If I use the FITfiletools corrupt time fixer the FIT files then upload (the tool makes the timestamps match).

I have reported all this to both Zwift and Garmin support, but not seeing a lot of action (both are as bad as each other in not actually reading the ticket, but I have manged to convice them of the issue).

Anyway - is anyone else having the same issue - I have found reports of it causing issues with Golden Cheetah during uploads due to the timestamp, but they did a workaround). I had a look at older Zwift FIT files and the timestamp issue does not look new, so perhaps Garmin have beefed up their checks recently.

duplicate post.