Zwift update in a loop

I tried to open Zwift today on my pc and got the update message. it dowloaded the the update, however it’s stuck on the update screen and looping. it goes from 4min remainig to 17min to 45min back to 5min. to 245min. over and over. I had already updated to version 1.25 a couple of days ago with no issues. running latest windows 11.

Hi @Tomas_Monroe

Welcome to the forum.

Did you check that there is not another window open waiting for you to click ok to give Zwift permission to update? It is sometimes behind the other windows.

Hi Gerrie, Yes, tried everything no other windows open. even re-started my machine. the update finally stopped afte a couple of hours and recieved the following message
“Update failed during patching. Error code Z117 at line 602 in Patcher.cpp. Please contact Zwift Support” I gues I’l keep trying

Try a different network connection. You have some downloaded assets that have failed integrity checks.

Thank guys, I re-booted vereything for ther third time and finally the update worked.

1 Like