Zwift suddenly can't find trainer

This morning I was up at 4.30 in the morning… to ride Zwift before a busy day… now imagine my disappointment when i spend the next hour and a half trying to get Zwift to connect to my trainer… All that time i should be riding and I’m troubleshooting instead… 

Background info:

  • Windows 10
  • Bkool Smart Pro hometrainer
  • ANT+ stick is 5 cm from trainer
  • Trainer connected fine for the last 1100 km
  • Trainer connected fine 2 days ago
  • I have changed nothing in my setup the last 14 days… (12 rides)

What i have tried

  • Reinstalling and updating ZWIFT
  • Restarting about 110 times
  • USB ant+ extender in different ports (all of them)
  • running Bkool simulator - find the device in 2 sec and is at 100% strength
  • running Bkool sim. - ANT+ FE-C is not showing up next to the trainer, so it must be enabled.
  • Left ZWIFT searching for 10 minutes

I spend so much time trying to make this work that it’s now too late for me to ride…

Now if zwift was a free program… then I might not be angry but, like everyone else, I pay for it, I pay for it to work.


Garmin programs are not using the ant+

Zwift tell me the last ride was on jan. 7th… though i did ride on the 15th… with some connections issues tho… (riders disappearing and reappearing again)


I can empathise,it is frustrating when Zwift starts messing around after previously been solid.

Just as a box-tick thing, has Win 10 updated itself anytime over the last couple of days.

Have you tried inserting the ANT+ device directly into the computer, that is, without the extension.

The riders appearing and disappearing is generally a server issue, probably not related to your pairing problem.

The riders appearing and disappearing is most likely an issue with your internet connection, not a server issue.

You can monitor issues at Zwift here:

I never said it was sever issue :slight_smile: but it was due to Zwift as I did a test and my 100/100 connection worked fine.

I solved my connection problem, it was because Bkool simulator was version 2.53 which does not have the option to enable ANT+ FE-C, I had to find and download the old version 2.50 for the button to appear.

Such a hassle… it would be awesome if zwift announced this :see_no_evil:

I can now see that my response was a tad bit (read: very) angry :stuck_out_tongue: I apologize for that.;