Zwift stuck in pairing screen

Four of us have had an issue where clicking on the OK button in the pairing screen, after all devices had paried, resulted in a “searching devices” message. This makes it impossible to get out of the pairing screen. In my case, this was on a normal ride and I just restarted Zwift. For my three team mates this happened while in the pen of a TTT after the banner had dropped. This meant that they could not ride.

  1. Anyone else had this issue?
  2. Any workaround that worked for you?

I had the same issue. I killed the Zwift app, then restarted it. Worked ok after that.

I am having the same problem today. I had been having problems with dropping heart rate and power etc. Checked and found my devices were pairing through Bluetooth when it should have been using my Ant+ dongle. After re-pairing to everything via Ant+ I found myself stuck too. I wish the pairing page showed how the devices were connected so you could confirm it is connected via Ant+ or Bluetooth depending on what your preference is. I ended up disabling Bluetooth in my laptop to guarantee I would only connect through Ant+. Just finished a loop around Ticktock without any issues. In answer to your question. I had to force the app to close and then restart. I have a theory it has something to do with the quality of connection with the paired devices. I obviously had a bad connection with the Bluetooth. It could be that even though the screen showed everything connected, the app was not satisfied there was a complete connection. For example if one of the sensors kept dropping out and coming back, this might happen. What about it Zwift?

It’s a bug. But just press Esc to bypass the pairing screen.


Happened the same to me today, pressed esc to close the pair popup but the UI should have a more clear action to close it

Thanks for the ‘ESC’ tip, will try if it happens again on my PC, any alternatives for iPad users (some of my team mates)?

1 Like

I tried this and it did work. Interestingly though I was transported back into Watopia riding all by myself. I finished my activity and even screenshot the route completion banner and while it shows up in my companion app activity feed it does not show up in my badges in the Zwift app.

I am having the same problem… My Apple Watch gets disconnected from the companion app every time I start riding. Have to reconnect it all the time.
If I only notice it mid event and try to reconnect, my iPad gets stuck on the pairing screen (exact same issue described by the OP).
Closing Zwift and opening again crashes when trying to resume the workout. Then it ends my ride and I receive a Strava notification of a synced workout… Happened with me twice already!
If someone ever finds a solution for iOS (iPad) users I will be much appreciated!!!

Hi @FredMaranhao

Welcome to the Forums!

This is one of those old and sporadic game bugs that’s been around for a long time. There is no solid workaround for this issue other than force closing Zwift and restarting the app.

I recently flagged up this issue to the Zwift developers and it seems they’re getting some attention on it, so that’s good news. Thanks for letting us know!


I’ve got the same issue on the iPad Pro and we can’t use the ESC button trick. I was in the holding pen before a TTT on ZRL and I was unable to get off the start line, very frustrating to let my team down!