Unable to exit pairing screen

If i enter the pairing screen from the world selection part (after the initial log in but before clicking ride) once i have made my selection and try and go back to the main screen whichever button I press a pairing screen pops up that has nothing in it making it impossible to exited the pairing section.

The only way I have found to get round this is to hold the stop button on the companion app.

Not sure I explained that too well but it is quite hard to describe.

this is on the windows version.

Tried pressing Esc? Not saying it isn’t a bug.

1 Like

I’ve seen the same thing multiple times recently (last two weeks), using iPad, iPhone combo with Tacx Neo trainer, Apple Watch as HRM. Only solution was to force quit Zwift.

Had the same problem yesterday. Only solution to get out of the window was killing Zwift in Windows Task Manager. After restarting Zwift it worked.

This happened to me yesterday too, on the pairing screen if I hit “OK” at the bottom a searching window opened as if I was trying to search for a signal to pair with. Hitting the esc button worked, and everything went as expected from that point.

Strange behavior, could be a bug with the new update? I usually let the automatic countdown move me past the pairing screen.

1 Like

ESC didn’t work for me.

Only hitting stop on the companion app without actually quitting got me back to the previous screen

Encountered this bug today. Pressing OK to advance past the pairing screen just brings another searching box up. Had to Esc past it, which worked.

I don’t always use a physical keyboard (i use the remote mouse app) so maybe that is why esc didn’t work when i tired.