Zwift started pairing the wrong device???


(Selh Teus) #1

So I have a Travel Trac Smart B+ Fluid Trainer. It’s got the little Misuro Elite ANT+ dongle that reads power and cadence. I didn’t ride for about 3 days then got onto Zwift yesterday and noticed it was reading my cadence all wrong. Instead of giving an accurate reading like it normally does it kept going from 30RPM to 95RPM or so (which is about what I ride at) by going 1rpm per tick, like it was counting up? Then it would count all the way back down. If I stopped pedaling completely it would still just gradually go down, not really reading correctly.

I noticed upon pairing it’s pairing with a “Elite 49” something controllable trainer, the cadence says “pedal brain” which I’ve never seen before and it is also showing a “controllable trainer” under that box that is never highlighted (as I don’t have one) as being an elite 49.

When I try to unpair the program crashes and it is not giving me a calibration option… What do I do? :frowning:


(David K) #2

When you have a bit of time to spare, please log out and exit Zwift completely. In your \Documents\Zwift\ folder, you should find a file called prefs.xml that stores all of your previous pairings. Please highlight it and delete the file.

If your Elite Travel Track, your Misuro B+, or the Power Meter you use allow for calibration in official third-party apps, I’d recommend going through each device one-by-one, applying any firmware updates, and completing a calibration. Afterward, unpair your devices from those support apps and ensure they’re no longer running in the background on your device.

Lastly, unplug your ANT+ dongle, give your PC a reboot, plug the ANT+ dongle back in and load Zwift. The game should generate a brand new prefs.xml file, but it won’t include previously remembered pairings. You’ll need to pair all of your devices again. Please let me know if you’re still noticing anything peculiar about the pairing or the device names that come up while you’re pairing.

As long as all of your sensors pair again, please try a ride or two and let me know if you’re still experiencing odd cadence. At that point, I’ll need to turn this post into an email support ticket and ask for a few resources for us to research through.