Zwift says connected but no signal. How?

I moved my Kinetic to a different spot in the room and had to unplug it. The next time I tried to use it, Zwift says it is connected but there is no signal. How can that be? It recognizes the device and pairs, and when I start a workout it makes the little noise it always makes, but there is no recognition I am doing anything. I have uninstalled and reinstalled the ANT stick, moved it to a different port, restarted the PC several times. Zwift says there is a Bluetooth issue but yet it still pairs. My phone recognizes the Kinetic so it’s transmitting. Not sure what to do here.

Hi @Scott_Gunn

Welcome to the forum.

It sound like the trainer is paired to another device.

The only thing I can think it would pair to is my phone, but it doesn’t have the app, so I don’t think it can actually pair. I turned off BT on my phone and restarted everything; still the same. My work laptop is nearby but I checked and it’s not recognizing the trainer in its list of devices.

Something nearby is probably interfering with the signal like a fan, move things away from the trainer and PC.

I think I sort of have it figured out. The original spot was about 8 feet from the PC and the new spot was about 20. Apparently that is too much. I moved it to a third spot that’s also about 8 feet and it’s working again. The BT symbol still has an exclamation mark on it suggesting something is wrong but now it recognizes activity. I guess that’s good enough.
Also, moving to the second spot was actually further away from anything that would cause interference, and the first and third spots are closer to interference.

get a USB extension cable for your ANT or Bluetooth dongle, that should help too.

1 Like