Zwift Run Speed & Cadence recognize device, but no readings

It’s been about a month since I jumped on Zwift to run, but when I returned yesterday and today to go for a run, I had issues getting my run speed and cadence to show any readings.

Yesterday, I tried to run with my Scosche Rhythm 24 HRM. Zwift recognized my HRM for HR, Speed & Cadence, but only gave readings for HR. So I was unable to record the run. It was fully charged, and had latest firmware updates.

Today, I brought my Milestone pod. Zwift recognized my pod for Speed & Cadence, but gave no readings. So I was unable to record the run. It was 3/4 on battery, with latest firmware updates.

I was running with my Aftershokz bluetooth headphones, playing podcasts from my phone and also tried from my Garmin Fenix 5 plus watch. I’ve done this before, but I’m wondering if something has happened in the last month that would affect any one of these bluetoooth devices output for Zwift.

Help? Thanks


I am not the running guru here. But in my attempts to run I found that you have to pair while walking to keep the sensors awake.

Zwift recognizes my sensors (they’re awake), it’s just not giving any readings on my speed or cadence. If I’ve ever had issues with my devices, Zwift usually just doesn’t recognize them at all. I was just surprised that it could see my devices, but couldn’t provide any readings…

Do you see speed readings in the paring screen.
I would try without the bluetooth headphones, i have seen some interfere with speed sensors on the bicycle.

I’m going to try again this week without the headphones, but I haven’t had issues before (with running footpod, scosche hrm, bluetooth headphones and recording on Garmin at the sametime).

Good luck, let us know if it works.

Run On.