Zwift on Android can't find Kinetic InRide sensor

I was excited to be able to finally download Zwift on my Pixel 2 XL today, but I was bummed when I tried to connect to my Kurt Kinetic InRide sensor (attached to my Road Machine dumb trainer) and Zwift could never find the trainer/sensor. When I switch to the Kinetic app, it finds and connects to the sensor immediately, so it’s not that my phone can’t find it it, just the Zwift app can’t find it. This is the original InRide sensor - is it possible there are issues with the older Bluetooth protocol in this sensor? The current InRide V3 has Bluetooth Smart, maybe that would work better?

My setup:
Google Pixel 2 XL, Android version 9, 11/5/2018 security patch
Zwift app version 1.0.31443
I was able to get to the main view (rider on bike), though obviously my avatar wasn’t moving.
I tried to connect to the sensor in and out of airplane mode (with Bluetooth on for both), with and without WiFi connected, but it made no difference.

FWIW, I am excitedly looking forward to any Chromecast support - the frame rate on my Pixel 2 XL was VERY smooth and SO much better than on my aging 2011 Windows laptop!


I have the same problem and I’m on a Samsung Galaxy S9 with the Kinetic Road Machine 2.0. Did you ever get yours to connect? I found a setup guide that says to connect the sensor within the Zwift Companion app under the settings tab, but there is no option to add sensors within my app…


Edit: check out the kurt kinetic instructions on connecting an android to zwift: Kinetic — Getting Started With Zwift - Bike Trainer it might be more helpful than my tips below

i had a similar struggle trying to connect my Kinetic InRide sensor to Zwift on my Macbook today. I opened Zwift on the macbook and it couldn’t find the sensor even though bluetooth on my mac was turned on and I was pedaling. (I also had no problem getting InRide sensor to connect to the Kinetic App on my iPhone).

I ended up giving up on bluetooth on the macbook and in Zwift, clicked the gear icon from “Use bluetooth” over to “Use Swift Companion”. Then on my iPhone (which is connected to the same WiFi as my Macbook), I opened the Kinetic app and made sure I disconnected the InRide sensor first, then closed the Kinetic App. Then I opened the Zwift Companion app on my iPhone and clicked on the bluetooth icon. At first it said to open the Paired Devices window in the main Zwift app (on my macbook), but then the Zwift Companion App found my Kinetic inRide sensor, and all of a sudden the InRide sensor showed up in Zwift on my Macbook and I was able to ride.

So key points:
*I had success using two devices, one macbook computer (with Zwift installed) and one iphone (with zwift companion installed)
*Zwift bluetooth on my macbook didn’t find my kinetic InRide sensor ever
*Zwift was able to find the InRide sensor using the Zwift Companion App
*Both devices must be on the same wifi
*Both devices must have bluetooth on (but more importantly the iphone)

*Download the Zwift companion on your phone and Zwift on the display device
*Disconnect the InRide sensor from the Kinetic app in settings. (you could toggle bluetooth off/on on your phone to be safe)
*Make sure when you open Zwift at the “Paired Devices” window you change “bluetooth” to “use zwift companion”
*open the Zwift companion app on your phone
*When the InRide Sensor shows up in Zwift, select it in “controllable” and/or “speed”, “power” and “cadence” until you see the start button appear.

Edit: these steps I went over above to use the companion app are detailed here: the steps are the same for iphone/android. The Native BLE option didn’t work on my macbook at all.

It took me some experimenting to figure out but I hope this helps. Was definitely a little frustrating to figure out, and I do IT support for a living.

I don’t know how it might work with one device. Maybe you could have the Zwift companion and the Zwift app open on one device? Not sure.

1 Like

Update: I had the opportunity to try a newer InRide sensor (v3, the green one) and my phone was able to connect through the Zwift Android beta without issue. Frustrating that I may have to spend money to be able to use Zwift on my phone, especially since BOTH the Kinetic Fit app AND the Zwift Companion app can find the older v1/v2 sensor.


Thanks for the reply, but the issue I’m having is that my Android phone (Pixel 2 XL) can find the InRide sensor with the Kinetic app and the Zwift Companion app, but the full Zwift application itself cannot. Based on my experience with the v1/v2 InRide sensor and the v3 InRide sensor, my guess is
either that

  1. The Bluetooth connection code in the Zwift Companion and the full Zwift app is different somehow, leading to incompatibility with the older InRide sensor, or
  2. The Bluetooth firmware in the v1/v2 InRide sensor is different than that in the v3 InRide sensor, leading to incompatibility with Bluetooth as implemented in the full Zwift app.

It is still very frustrating that the Zwift Companion appears to work with the older InRide sensors but not the full Zwift app. I would think that two apps within the same software company would be compatible with the same hardware, but that doesn’t seem to be the case, sadly.


Ah I see. I’m saying that I’m also having trouble getting the green v3 inRide sensor to connect to bluetooth via the full app (except in my case the full app is on my macbook, so I think we’re in the same boat. Sounds like It’s an issue with Zwift+v3Inride. Maybe we should report this issue to InRide and see what they say as well? Wonder if others with the green v3inRide also have issues connecting to the full app.

i just bought a brand new road machine smart because it said it was compatible with zwift pc and android app. i shouldn’t have to spend another $50 to “upgrade” it

1 Like

Hi there!
I have huawei p20 pro and I could not connect Zwift with kk inride2 too. Definitely the problem is in zwift android app…

Im having the same issue with my Galaxy S9+. Android Swift App is not finding my Kinetic Sensor. Have you found a solution? Any word from Swift?

Yeah i found a solution. You need to buy the green inride sensor for your kinetic. Its the inride3, Amazon has it for $50, and it works pike a charm. The new sensor has bluetooth which is what Zwift requires, wheras the older black versions only have ant+. Just pull the old black sensor off and stick on the new green sensor. :grin: You can also calibrate it and update the firmware using the free kinetic app. A good calibration will be 1.5-2 (it gives u a number after calibration)

Interesting, did you have to replace the Magnet as well or just the sensor?

same magnet works perfectly

Has anyone find a workaround for this? Companion app seems to detect the sensor without any problems, but the zwift app cannot do the same. Maybe the app is lacking the appropiated drivers to work with the first version of the inRide sensor.

Any solution Zwift?

And still the same problem…Companion app can detect the inRide sensor, but the regular zwift app can’t. Is this going to be fixed or do I really have to go buy a new sensor!? Seems a bit ridiculous given it works with the zwift companion app.

Same problem here.
Huawei Smart T5
Kurt kinetic road trainer smart

Zwift app don’t find the trainer.

Huawei can find it. And Kinetic app can find it too.

Also have a Iphone that can slo fint the trainer.

The problem is with the Android Zwift app.

Any solution?

Is Zwift going to solve this issue? As many users have said before, shouldnt be a problem as the companion app works great with the old sensor. Now that everybody is using Zwift to ride, i think they should take a time to review and upgrade the drivers to allow us, old kinetic owners, the chance to use the Android App. For sure, that would give us one more reason to continue renewing the subscription.

I am experiencing the same problem, and the V3 is out of stock. any solutions in sight @JUAN_PEREZ1 or anyone out there?

Same here, and the v3 sensor still out of stock. I have a galaxy S8

I’m having the same problem except I’m using v3 with an galaxy s21.

The Zwift app needs permission to use location on your phone but not only that, you must pick “only when the app is running” and not “always.”

This may resolve the issue.