Zwift not uploading to Strava or Zwift Companion

My Zwift rides are not uploading to Strava or Zwift Companion. I have been using Zwift for 18 months and have not had this problem in the past. Strava shows up in white on my zwift screen after i finish my ride as it should, but when i select ‘save’ the ride does not upload to my Strava account. It also seems that the ‘save’ process is being cut short since it ends very abruptly when I am saving my ride. Zwift - can you please help me with this? Thanks

Hi @Chris_LaFemina

Welcome to the forum.

Have you tried to un-link strava from Zwift and re link it.

1 Like

Yes, multiple times

does it say “activity details cant be loaded” in the companion app? Sounds like you are having network issues and the ride isn’t saving to Zwift’s servers.

Hey Chris,

So what troubleshooting steps have you tried so far?

In which platform have you tried connecting your Strava account? And what is your Strava account linked to? Do you sign in to Facebook, google, or just the regular login?

For me, I have to connect to my.zwift.com and connect it from there since my Strava is linked to my google account.

That seems to be the case, although there is no message that activity details cant be loaded. Right near the end of the Uber Pretzel yesterday i lost connection for a second. I was able to reconnect and finish the ride from there, but that ride did not upload.

Thanks for this Jofran. I just use the regular Strava login. I am trying to upload the zwift ride from an ipad to my strava account on my iphone. I have never had a problem in the past as the upload was automatic. But now it is not working. I was wondering if this was an issue that others had this past weekend as well, but that does not seem to be the case.

Strava did update their app recently, have you check your app if it’s the latest version?

Also, why not check the Zwift Companion App? check your activity section if your ride is there.

For the mean time, you can manually upload it maybe on your next ride the issue might be gone. https://zwiftinsider.com/retrieve-lost-ride/

Thanks. My rides are not uploading to the activity section of my Zwift Companion App either.

This indicates your ride was not saved correctly due to a network dropout. If it didn’t make it to Zwift’s servers it will also not make it over to Strava. You can manually upload the fit file to Strava however. You will not be able to restore the ride in Zwift, they do not allow manual uploads.

Thanks Mike. Any advice as to what I should do to resolve this issue going forward? I am not so worried about losing just one ride - even though that ride was my first time completing the uber pretzel - but i would really like to get this sorted out for future rides.

If you have the option of directly wiring your device to the modem/router then that is probably the best solution, but ISP’s can still go down and drop your connection if they are having issues on their end. I don’t think there is a way to completely stop this from ever happening. In 18 months I think I have only lost 3 or 4 rides on a pretty weak wifi signal based on where my setup is in the basement as far away as possible from the router. If I was able to be closer, I bet I would not have lost them.

1 Like

Thanks Mike. I did a ride this afternoon and the upload worked. Maybe just a glitch in my connection yesterday. Terrible timing as I was at the end of uber pretzel but at least i am back up and running now. Thanks for your help. Much appreciated.

Me too… I save on Zwiftcompanion and didnt go to TPeaks or Strava, both are configurated

I have the ride saved at Zwift Companion… but nothing goes to strava or TPeaks :pleading_face: