Zwift Companion App does not upload to Garmin Connect

(Luca) #1

Hi there,
since some days I was using the Zwift Companion app to stop the ride and save my activity. But while doing so the ride was uploading only to Zwift and to Strava but not to Garmin Connect. This was not happening weeks ago and I was wondering that maybe something was changed on Garmin side… but yesterday I’ve observed better and on the Companion App when I’m saving the activity the Garmin connect is not highlighted and additionally the name of the activity is just "Zwift - " while if I save the activity through the in game menu then the Zwift activity gets a proper name, i.e. the name of the race, plus the Garmin connect (as well as the Strava) upload option is highlighted and in fact the activity is automatically uploaded also to Garmin connect.
So in my opinion there is a bug here on the Companion App.
Cheers and Ride ON!
Luca

(Lauren) #2

Rides not uploading to Garmin Connect recently happened, and our team is updating the status of this known issue here.

In this forum post, we did receive an update on the problem a week ago:
Update #1
We do apologize for the inconvenience! We’ve had delays on uploads to Garmin and are working to improve that delivery speed and will be reprocessing those activities. So any activities over the past few days that have not yet been uploaded will not be lost and will eventually be processed. All new activities should be uploaded without issue.

Since you still are experiencing problems, I’d like to invite you to write a support ticket so we can help look into the issue. As a friendly reminder, please make sure your Companion app and Zwift app are up to date.

Thanks!

(Luca) #3

Hi Lauren,
thanks for your reply!
My issue was only appearing in case of saving the activity via Companion App. With the on screen menu of Zwift I’ve never had issues with uploading activities to Garmin.
I’ve seen that today a new release of the companion app has been pushed on the AppStore. I’ll try it as soon as possible an report you back if the issue has been solved.
Bye,
Luca

1 Like
(Luca) #4

Hi,
today I’ve tried again to save the activity from the Companion app after last week app update. As can be seen in the screenshots from my iPhone on the save page there is no option of uploading the activity to Garmin even if in the other screenshot is shown that the Garmin account is properly connected.
On the other hand from the picture taken from the TV screen it can be seen how there the Garmin upload option is present.
So it seems that the “save” functionality from the companion app is not allowing yet to upload the activity to Garmin Connect.
bye,
Luca

1 Like
(Luca) #5

It’s me again, I forgot to mention that with the companion app also the name of the activity is not the same as the one you get automatically from the in-game save menu. Here in the example above the Companion app is showing “Zwift - 20/03/2019” while the in-game save menue is taking in the name of the activity the workout name: “Zwift - 3x13m Climb”.
I would better like to have also on the companion app the activity saved with the name of the workout instead of the simple date.
Ride on!
Luca

1 Like
(Lauren) #6

I brought up the issue with my team and they said it definitely sounds like a bug. If you could write in a ticket so we can investigate further, that would really help us address this issue. Thank you so much!