Zwift not uploading to strava and garmin

Hi there

Suddenly zwift stopped uploading to strava and Garmin. It still uploads to Training Peaks as usual.

Now I have tried to download the .fit files manually and upload them to strava, however I get a “Error Processing Activity” which can indicate there is something wrong with the file. I just can’t figure out whats wrong.

I have read that this can happen if the ride is stopped or I have somehow lost connection during the ride, however, this does not seem like the case. On my.zwift and companion app the rides looks normal.

I have tried reconnecting my zwift account to both strava and garmin without any luck.

Any suggestions what to do?

Thats definitely a strange one given your activities look normal in CA. You could try and re-connect Zwift to Strava, and for fit files with issues, run them through to see if that can help fix the problem.

1 Like

I tried to ride with my iPad. Still same problem. No upload to strava but its uploaded for TP.
Can’t figure out what’s wrong with the files and why it’s suddenly a problem. I just can figure it out, since it’s very sudden and nothing changed on my account. My internet is the same. Hometrainer is the same.

1 Like

I have the same problem. I did all the things that some one could think to solve that problem but nothing change. Strava and garmin doesn’t have my activity. confused:

1 Like

It’s very frustrating not being able to figure out what’s wrong. Since there are no segments in the zwift app, strava is still a very important service for comparing times.

The only thing I have changed is my profile name, however I would be surprised if that’s the real reason of the sudden upload stop

1 Like