Zwift not responding after successful login

Hi, I’m trying to get some help here. I just downloaded the zwift app and cannot get pass the “successful login, Ride on.” screen, the zwift app becomes not responding.
Log files shows last line “[0:03:57] PairingScreen CTOR”.
Now before you ask, I have tried updating windows, updating graphics card driver, remove and re-install zwift and reboot multiple times. But everytime the same problem occurr. I’ve looked up on google and the forum but nothing helps. I’m running out of ideas of what is going wrong.
Here are the specs:
Zwift launcher: v1.1.4
Game version: 1.24.2 (100840)
Windows 10 Home 21H2 19044.1682
CPU: Intel Core i5-6200U
Graphics card: Intel HD Graphics 520 (integrated) and Nvidia GeForce 940MX

Here is a screenshot at the time when the problem occur:
(It says: successful login. Ride on!)

Any recommendations of what I should try?
Thanks in advance.

Hi @Chuhan_Chen

It’s possible that you’ve been impacted by a known issue where some Zwifters running Zwift on a PC encounter longer than expected load times and/or performance issues with the app.

As far as I know, Zwift’s developers are looking into this issue, so one thing I can suggest is for you to try to have patience with Zwift when launching the app and be sure to give it time (perhaps several minutes) to load after pressing “Let’s Go” on the Launcher.

If you click on the Zwift app window in an effort to speed things along, this may cause further delays and show “Not responding” in the app, so we advise that you not do this.

Also, if you’re using an older computer with hardware that is perhaps 5 or 6 years old, it’s also possible that there may be some additional underlying issues on your PC which are contributing to general slowness launching the app. For tips on how to improve PC performance in Windows, I suggest you have a look at Microsoft’s article​.

Hope this helps!

Dear Support,
I also suffer from this issue. With your suggestion to wait for more minutes, I tried and failed. One of my tries is to wait for a whole night, but nothing occur finally. I have the similiar configuration as Chunhan_Chen. I think it might be something wrong with the PC hardware. Anyhow, I am stuck here. Will Zwift have a plan to provide support to older PC such as 5 or 6 years ago?

1 Like

I am also suffering from this issue.
I usually use an iPad to run zwift and no issues with the ipad but to get a specific kit I need to load up my PC as this feature is not available on the ipad.
This is the first time I have tried to run zwift on a PC since the recent update.
I can log on and get to the Home Screen but when I try ride and load a world to be able to get a new kit required for this week’s TTT , zwift just gets stuck on the blue Loading Watopia or e.g. London screen. I’ve spent the last 2 hours trying to load a world. Can you help please. Thanks.

same issues here, actually running I7 core, so not dated technology, same issues, just loads up, connects to my trainer, then when I start to navigate, just stops working and then “not responding”

has anyone come up with solution to this issue?

FWIW, windows version and was running on my older laptop just fine until I replaced it and now unable to use the app on much newer more modern pc with better hardware

I have been also suffering from this issue for about 1 year. Nothing improved

Hi, I’ve managed to solve this issue. Are you using “sogou pinyin input”? If you are, change it to other input method (e.g. microsoft) before starting zwift.


OMG thank god I found this post! Yes once I switched away from Sogou Pinyin input it loads successfully. Thank you!

Yes! the software “sogou pinyin input” is the key! Thanks Chuhan

Not only “sogou pinyin input”, but also “微信输入法” will block the app after login…
Switching the input method to “Microsoft Pinyin” works.
Thank you!

1 Like

Thanks for solving the issue!! I guess the PC app doesn’t like other keyboard input

1 Like

Cannot correct issue of freezing Customer service is horrible

I Need help

what device are you using?

Did you actually get through to customer support? I ask because many people can’t figure out how to get past the dismal chat bot, but the real support people hidden behind it often do a good job. Also if you get routed to an “ambassador” that means you’re not actually talking to the Zwift support team, but they have the ability to route you to an employee by pushing a button.

Hi @Victoria_Cerami, Welcome to the Zwift Forums!
Fernanda here, part of the support specialist team at Zwift.

Definitely, the freezing of the App is very frustrating, I assure you that we can help you in this freezing situation with your device, I will follow up on the ticket you have open with our Customer Support team! Don’t worry! We are willing to help, and we will find a solution for you.

I’ll be in contact with you via e-mail.