Zwift not remembering imperial units

Ever since an update last week my Zwift has switched to KM from Miles.

I can change it back in ride within the settings, but then when I exit and boot back up the application it defaults back to KM for the ride selection and in ride metrics.

Can this be resolved please?

Try logging out of all devices with zwift installed. Then change preference here https://my.zwift.com/profile/edit (or toggle back and forth) save. Try in game.

Thanks, will try setting there.

I have logged out and I’ve even reinstalled the whole of Zwift on both PC and Mac.

I find that Zwift will match whatever setting you have in Companion app, if you open the Companion app before opening Zwift.

I like to run Zwift in KM and the Companion app in miles. If I forget to change the companion app back to KM before my next ride, Zwift will be in miles the next time I log in.