Zwift mobile app malfunction after update today

My mobile app would work for about 30 seconds in the ride mode (recognizing that I am signed in to zwift on the computer), allowing me to get my bluetooth trainer recognized.  But then the mobile app reverts to the mode it is in when I am not signed on to zwift, and it says no signal is coming from the trainer.  So I can’t ride at all because you have to have the mobile app open for a bluetooth trainer to work.

@Andy: Try the troubleshooting steps in this article to see if they help. If you’re still having problems after that, you can submit a support ticket, and we’ll be able to help further. Thanks!

I am having the same issue…



Along with ‘no signal’ status on my devices. However, Bluetooth link is evident and I have internet connection. If I ride, my wattage and cadence change but rider is stationary or just cruising.

Same issue!!! :frowning:

Same issue; I submit a ticket to Zwift; I let you know when I get an answer

I still haven’t an answer from Zwift support but I’d like to add that I have these “no signal” status with all BLE devices (trainer, HR monitor and cadence sensor). And in addition, as I was able to start a workout, the default set ERG-mode didn’t work. But that didn’t matter because my trainer lost the BLE pairing after eight minutes.

Btw: I run the Zwift mobile link under Android 7.0.

Same issue. I get a momentary Bluetooth connection, then it is lost and I get ‘No Signal’. ANT+ devices (HR & Cadence) continue to connect.

I’m using CycleOps Hammer, and phone is Google Pixel XL running Android 7.1.2 and ZML version 2.0.2 (251)

I got the first reaction from support. They asked me to give more informations about my equipment (especially Android or iOS user!).

Last night I tried to pair the trainer via ANT+ FE-C (controllable trainer) and ANT+ (power source) while I paired the cadence and HR sensors via BLE. That worked fine for the whole workout. I didn’t have the “no signal” problem with that combination. That surprised me a little bit.

Same issue - also running Android.

I borrowed and iPad and set it up instead of my android phone… It worked for the most part… My android phone get the same response as the one listed above… I am not saying buy an iPad, but until they fix it maybe a work around for you…

Seems to be a new created bug in the Android version of Zwift mobile link since the update last Friday. I’ll use the ANT+ (trainer) and BLE (HR Monitor and cadence sensor) combination until they’ll fix it. 

I hope that support comes forward and at least answers my support ticket. I have not even got an initially response after 3 days. I do not see a workaround in sight so I might need to switch to another training app as I do not have an ANT+ setup.

My most recent response was this:
Thanks for reaching out.

I’m sorry you are having issues, and you are not alone. We have received several reports of the same thing, and our QA department is currently investigating.
I will keep your ticket on-hold until I have more updates.


Member Experience Team

My ticket response included, “We are currently tracking (and fixing!) a bug”

I raised a ticket and got the following responce;

I have tired the above but no luck. Will send the log files and see what feedback I get and post here. I have tired removing all firewalls etc but no joy. As above, I am running an Android phone for the blue tooth link, which seems where the issue is at perhaps as opposed to firewalls etc. I am not particularly IT savvy, so this is all a steep learning curve…and a pain in the ■■■■. 


No further reaction from support until now. It is quite disappointing that they issued a major bug with an update and are not able to fix it for more than 10 days.

I have the same problem too. Does anyone know of a way to downgrade to the previous version of the app?

So after a monumental amount of playing with firewalls, router and wireless settings all to no avail, this morning I tried removing the current version of ZML on my phone (andoid phone) and adding the old version. I found the old version on the zwift website (an APK file). Tried it this afternoon and BINGO, all go.

Only problem is, i have had to remove auto updates from my phone. So its a short term fix but for me, seems to be working again.

I have reported it to Zwift support as i had a ticket open and asked when they will be able to provide a fix to the current bug.

Unfortunately, I cant past the file here but you should be able to find it on their website.