Zwift macOS ignores OS Bluetooth privacy settings

I never want my devices connected via Bluetooth. I have an ANT+ connection that is near my trainer and my heartrate strap, whereas my computer (and Bluetooth Antenna) is further away. My headphones are Bluetooth. I get interference when zwift uses Bluetooth that causes both garbled audio and power drops in the game when I connect to devices via Bluetooth.

Apple has made Bluetooth one of the technologies that an app has to ask the user permission to use. I have specifically said “NO” to Zwift using any sort of Bluetooth.

Despite this, I still see Bluetooth connections being made when there should not be any made. I do not have companion running (it’s so flaky I gave up on it completely). I have also filed this as a bug with Apple, as there should never be a way to bypass the privacy settings. However, it’s also up to Zwift to honor the privacy settings of the user, and if I have said No, Zwift, you cannot use Bluetooth, Zwift shouldn’t be using a workaround to get access anyhow.

Hi @J_Thompson_IA

So, just for clarification, you’re saying that you’ve disabled Zwift’s access to Bluetooth in the Mac privacy settings, but in-game at the Zwift pairing screen, the app still indicates that BLE is turned on (e.g. the little Bluetooth symbol is active and pulsating)?

Also, if I’m understanding you correctly, you don’t want to use Bluetooth on the Mac at all, correct? If so, have you tried simply turning off Bluetooth as explained in this article?

I don’t want to turn off Bluetooth as my AirPods need it. I just want your app to follow the privacy settings.

Hi @J_Thompson_IA

Please confirm that you’re disabling Zwift the Privacy settings as follows:

  1. System Preferences > Security & Privacy > Privacy (it’s a tab) > Bluetooth (found if you scroll down on the left).

  2. You should be able to check (or uncheck) the box to make sure Zwift is an app allowed to use Bluetooth (or not).

  3. If Zwift is already unchecked, then check it, and uncheck it again to make sure the setting sticks.

It would be helpful if you have a screenshot showing proof that your privacy settings are configured correctly also. I’m guessing that Zwift’s developers are going to want to know this for certain if this is something that needs to be investigated as a bug.