Zwift losing connection with power meter

Since early September, Zwift keeps dropping connection with my PowerTap, Garmin Speed & Cadence Sensor and HR monitor.  My Garmin 510 is not dropping any of these connections.

Zwift will sometimes just drop the PowerTap, but keep tracking the other devices.   Alternatively, Zwift will keep the PowerTap but not keep the speed and cadence sensor.  I have swapped out USB devises and I still have the same results.

1 Like

I have had similar problems for the last month or so using my Kickr and the cadence sensor it came with.  The cadence monitor sporadically drops to 0.  I tried changing the batteries, and re-connecting my ANT+ dongle, and that didn’t help.

I’ve also noticed that the power numbers for London, specifically through the tunnel and on Box Hill, are not steady.  I was rolling up Box Hill in my 50x13 and it was only saying 200w.  Not sure if that is related to connection problems, or just something weird with London.  Watopia and Richmond seem to be better, but something is just not right with London.

1 Like

I’m sorry to hear about these problems! The good news is that they’re likely signal issues. While a bike computer may not drop the signal from your sensors, it’s not scanning for them at the same intensity that Zwift does, which makes the dropouts less visible. The ANT+ signal can also be pretty easily interfered with, so make sure you don’t have anything else nearby that’s active on the 2.4GHz band.

If you prefer to keep using ANT+, I’d recommend going over our ANT+ signal article. What I’d really recommend, though, is trying to connect over BLE instead. If it works well over BLE, it would confirm it’s an ANT+ issue - if it still has problems, the issue is more likely to be either battery or hardware related.

Finally, there is ZERO difference between how your signal is transmitted over different courses, so these issues will be consistent, no matter which course you’re on. You can troubleshoot whenever you have time.

Same problems, zwift lose connections to HR monitor and tacx trainer.

Worked smooth during trial, first ride as a subscriber all signal dropped after 1 hour. Had to restart zwift to regain signals.

Next ride same thing happened after 1hr and 5 min, today it happened after 16 minutes after restart it happened after 5 minutes.

Ended up using trainerroad at the same pc with no issue. Unfortunately I highly doubt it is a coincidence it worked with TR.

Using tacx ant adapter 60 cm from HR and 80 cm from trainer

1 Like


Have you gone through these troubleshooting steps:

I have done 3+ hour rides with no ANT+ drops and others have done much longer rides with no issues.

Zwift uses more data then TR does so you really can’t compare the two.


I’d say all signals drop out, and restarting the software is the only thing that will regain signals.

While I got full ant signal from my phone using tacx app. Even tried relocating ant adapter putting it next to trainer. Still in the device manager I could not connect.

Even trainerroad uses less information the fact is that I get some signal while I get none in zwift. Just blank.

It might be compatibly problems with my setup, I wouldn’t deny it. I’ll hope I can solve the issue since zwift is more engaging.

1 Like

I had the same problem. Lost all signals including hr. I tried repairing but did not work. Restarting the program reconnected everything. But I was pissed, lost my motivation and went for a beer. Hopefully this software glitch won’t be a common occurance.