ANT+ total disconnection


(Robert Andersson (V) RAZ) #1

Hello!

This is the third off-season I ride Zwift and have been very pleased with it.

Now I have got an annoying problem. Every two-three times I ride, the ANT+ connection goes out totally and the screen reports “- -” Watt and the rpm and bpm are faded. When looking at the pairing page all devices report “No signal” but the ANT+ symbol is engaged. When trying to search for the devices nothing is found. Pull out and put in the connector doesn’t help either. The only thing that helps is to shut down Zwift and restart it. Once I have managed to pull out the connector, leave the pairing page put in the connector and once again go in to the pairing page where I managed to reconnect all devices again. My Garmin 1000 continues to receive a seemless stream of data while this happens. Something goes wrong in the computer. If it’s Zwift or any other application. I don’t know.

I would be pleased to get serious ideas about this problem. But not the usual, buy an extension, turn off bluetooth, set wifi to channel 1, try another port and antenna etc. I have been through all that and it’s not “normal” drops we are talking about. It’s total disconnection from Zwift.


(Andy Lee) #2

Hi.

I’ve seen similar issues recently (2-3 rides over the last couple of weeks maybe). In my case I was (eventually) able to reconnect after switching the trainer off and on and waiting a while, but it wrecked the workout. It also dropped out again a few minutes later.

I was using ANT+, and have the dongle right next to the trainer. I had no such problems for the first 10+ months of use previously.


(Jason K) #3

@Robert: Have you tested your ANT+ dongle with another program? If you’ve already gone through all our standard troubleshooting and see this in another program as well, it’s likely a problem with the ANT+ driver or dongle itself.


(Nigel Doyle) #4

I’ve had this. What resolved it was checking the hardware devices in Windows and seeing that there was an issue with the USB devices. Installing a new driver fixed things. I also suggest putting your ANT+ dongle in a plastic bag to keep sweat off it. That plus an extension lead so the dongle is very close to your power source.

Also instead of using Wifi you’ll get better results using powerline networking where you use the wiring of your home as a wired network. Just a matter of buying the 2 special power plugs and plugging one into the power socket by your modem / router and the other by your Zwift computer. You then plug network cables into the sockets to connect things up. Faster and more reliable.


(Robert Andersson (V) RAZ) #5

Thank you for your answers!

Jason: I haven’t yet tried any other program, but I have registered for 30 days free with Bkool Simulator. I will try this the coming days. I have had the same issue with two different dongles, Tacx with its inbuilt extension and Garmin stick with 2 meter extension.

Nigel: I’m also looking at the things around the USB, hardware and drivers and also turned off as much as possible in autostart which may interfer. I have shut down both the computer’s and the phone’s bluetooth. I don’t need powerline networking since I have installed wired network in the house. I now have tried to run the computer wired. This weekend I ran two 45 minutes sessions without any problems. The coming week I will try to find time for a run longer than 90 minutes.


(Soren Bay [X]) #6


I have the exact same problem that Robert reports : during a Zwift session the connection to HR monitor and power meter is lost and Zwift shows “-.-”.

Connection can only be recovered by restarting Zwift. I am using an extension cable and ensured that Windows 10 do not use power save mode on the USB dongle.

I have attached the Zwift log file. The problem starts  10:32:09

Cheers,


(Wox Wox (ZRG) ()) #7

Hello,

 

my problem is exact the same as Robersts.

Robert: Have you a solution about the Problem?

I won’t test to use a BT Dongle - have you (Robert) test this?

Sincerely

Wox


(Bart Petroons | BZR | (C)) #8

Experienced the exact issue now 2 times in two weeks. Never had this before. I heard the Windows sound of disconnecting/connecting a USB device (or when finding new hardware) so I guess this is a Windows power saving issue or driver issue. I now made sure USB device won’t do power saving and made sure PC is in high performance modus never putting devices to sleep. Hope this will keep the issue from re-appearing. If someone found another root cause please let me know.