Zwift is freezing every two to five minutes.


(Alex Trimes) #1

Everything seems to work fine, but after an almost constant time, Zwift freeze. I can still heard the sound… but my avatar stop (without lunching the pause mode).

I’m on macbook pro with latest OS X, Zwift and Tacx Genius smart firmware…


(Dave Musselwhite (M70/ZBR/TeamZF/PACK/RO) #2

The same happened to me again yesterday.  I’m using Macbook Pro as well with all the latest updates.  I tried several times to ride a Richmond circuit but it locked up every time and needed a forced quit on the application.

As a last resort I tried the 20 FTP test on the Workout Menu and it worked fine for an hour!  It did not upload the results to Stava though.

Its getting to be obvous to predict when I am going to have problems though. If it takes 2-3 minutes to log on to the system I’m pretty sure I am going to get lock ups and the need to manually shut down the programme.

 Some days the login process is virtually instant and everything works fine.  Nothing has changed on this end so I tend to believe it’s a server problem.


(Alex Trimes) #3

Thanks Dave, did it work fine before?


(Jon Mayfield) #4

Alex, how often is this happening? We see that you were in for an hour today on OSX 10.11.  Is it your newer OSX 10.11 machine having issues?


(Dave Musselwhite (M70/ZBR/TeamZF/PACK/RO) #5

@Alex

No this is an ongoing problem which I have raised in Ticket 16639.  Some days Swift works fine and other days it will run for approximately 5 minutes then lock up completely.  Like you I can still hear the sounds but it requires a Forced Exit to quit the programme.

I do know that if the login process is really slow and takes 3 - 5 minutes I will get nothing but problems.  


(Jon Mayfield) #6

Can you guys try unplugging and re-plugging in the ant dongle?  Both of you are on the same machine and OS and I also see some of the sessions had no ANT dongle some of the time.  

 


(Dave Musselwhite (M70/ZBR/TeamZF/PACK/RO) #7

@Jon  I’m planning another ride tomorrow and I will try that again.  I’ve already tried that and had no success.  I’ve also found that if I have to force the programme to quit my Ant+ devices are not detected on the Pairing screen unless I unplug and reconnect the USB cable connected to the dongle.

Doing this will get the device pairings back but does not cure the problem when I start riding.  The programme will freeze causing me to Force another quit and so on.

Of course this does not explain the days when nothing goes wrong and everything works perfectly.

I’ve done some searching and I have come across some reports that the Garmin Ant+ dongle sometimes is not detected, or drops out, when running OS 10 El Capitan on a Macbook.  It’s late here and I’ll do some more research tomorrow.

 

 


(Alex Trimes) #8

I still have the same freezing. Sometimes, it stops for just 30 secondes… 

And yes, after a relaunch, it seems harder to get the ant+ peripheries detected. 

I hope the days with no glitches are coming… 


(Stuart McLaren) #9

Guys,

I’m also on a mac book pro, late 2013, with new tacx bushido smart trainer. I’ve been persevering for near two weeks with Zwift, sent in a ‘ticket’ (no answer, yet they have acknowledge it), reinstalled it and installed the resent IOS update, all with no change to this massively frustrating problem. I did manage to get through an FTP test with only two ‘hangs’ and managed to save the ride fortunately. Yet the norm for Zwift with my set-up is as described in the initial post above. 

Going to try another reinstall as it worked ok for 1 session but crashed at the end of my ride and i lost it. 

In my opinion the fact nobody is stating its a hardware issue points more to the software, but is it Apples or Zwift who need to fix it? We cannot update the graphics drivers as Apple have this totally under control, apparently! Yet no reply or guidance from Zwift suggests they don’t know either!

(I’ve also tried Zwift on my mac mini, of the 2012 vintage, and it has exactly the same problem)


(Alex Trimes) #10

Stuart, I’ve been able to use it. I guess it’s all about Tacx and mac. After the first freeze, I need to stop pedaling and wait… After 1 or 2 minutes, the game is back and It runs fine for the rest. 

 


(James WB) #11

I’m having the same problems on my mac too. Spent 45 mins trying to get it working, switching on/off my mac, switching on/off my wahoo trainer and removing/reinserting the ANT dongle. I’m also finding that the link between wahoo and Zwift means that the incline has no impact on the trainer. Frustrating at best. 


(Steffen Claus ZZRC) #12

Same problem for me! Freezes 2-3 times during the first couple of minutes (race and workout mode, watch mode shows no issues). After the first 3-7 minutes, no further issues arise.

Netstat shows lots and lots of open connections to an AWS instances. Is that expected behaviour?

I am using the Tacx vortex Smart with an USB Ant+ dongle and a Garmin heart-rate monitor.

Hardware specs:

  • Macbook Pro Retina Mid 2012 15 inch,

  • 8GB Ram 1600 MHz DDR3,

  • 2,3Ghz Intel Core i7,

  • Nvidia Geforce GT 650M 1024 MB,

  • Yosemite 10.10.5.

 

Would be really fine to sort out theses issues, as racing is quite impossible this way.

 

Thanks


(New Scot (C) ODZ Euro Decaf lead) #13

Similar problems for me tonight - I don’t see a solution response to this from earlier this year - has anyone found a solution?


(Alexandre de Trimes.org) #14

Yes. I’ve a solution. It’s real read to your wifi connection. When you freeze, desactive your wifi and put in back. If you want to avoid this problem, you might need to play with your router


(Tazio Nuvolar (CLS)) #15

I’m having the same issue with the program hanging/non-responding at indeterminate points during a ride.  Video freezes but sound continues.  I suspected wifi as the culprit too and switched out to a hardwire ethernet cable and I still experience the problem.

Perhaps it’s a networking issue above layer two?  The next time this happens I’ll disable and reenable the ethernet connection on the Mac to see if this does anything.

When the program hangs, it’s usually for two to five minutes and when it comes back the group I was riding with disappear.  Needless to say I’ve run down my group on a couple of occasions after this happens–so at least there’s that bright spot. :8)  In my experience, just because it unhangs doesn’t necessarily mean I won’t experience the hang again during the same ride. :8(

If it hangs and I kill the process and restart the program, that resolves it, but it almost always hangs again at some point.  I don’t think I’ve completed but one or two rides without any hangs.

For what it’s worth I’m using Mobile Link which connects to the Bluetooth cadence/speed sensors on my classic trainer.

Any ideas?

Zwift Ver: 1.0.16192

My hardware:

MacOS Sierra

Version 10.12.3

Mac Mini (Late 2014)

Processor 2.6 GHz Intel Core I5

Memory 8 GB 1600 MHz DDR3

Graphics Intel Iris 1536 MB


(Tazio Nuvolar (CLS)) #16

Did an experiment this morning.  Started a workout and the program hung within 40 seconds.  Deactivated the ethernet service.  The program resumed momentarily then froze again.  Reactivated the ethernet service and as soon as an IP address was assigned and an internet connection established, normal program operation resumed.

The program hung two more times in the first ten minutes and each time, the procedure above returned the program to normal operation.  This happened one more time within the one hour ride.

If one of the Zwift developers needs any debug traces or process inspection debug info when the program is hung, let me know and I’ll gladly provide.

Thanks.  I want to like this program.


(Eddie Johnston) #17

Same issue with freezing except it’s on the feed to the Tv from  iPhone 6s via hdmi cable, iPhone working the app ok so no wifi issue just set. Just zwift works for about 5 mins via hdmi then freezes on Tv and continues on iPhone