Zwift Hub maximum difficulty

Hello all,

Just jumping in here to see if anyone is having the same issue. If it’s just a bug or what!?

The trainer feels like I’m constantly climbing a 10+ degree slope even going down hill on the game. When I enter a world the first few seconds feels like max slope. Everything has been working smooth up until the past few days.


Hi @Daniel_Lambert welcome to Zwift forums.

Shuji at Zwift HQ here. Go into the Settings menu of your game and check the slider for Trainer Difficulty. Is it set to Max? This would cause the symptom you’re describing. Try sliding it back to the middle (50% is the default setting)

Thing 1 to know : The Settings menu is context-aware, so the game must be paired to your trainer’s Controllable signal for the Trainer Difficulty slider to appear.

Thing 2: If the slider reverts back to Max on its own - you may be running into a known issue we thought we had solved in game version 1.32. Join us on this thread if that’s the case.

1 Like

@shooj ,

Thank you for your timely response!

I did look into the trainer difficulty and a few more questions have sprung. (Note: I have been using the trainer difficulty slid to max since day one and have played with the slid a few times to test the differences. I haven’t seen a need to decrease from max with my fitness and physical bike gearing.) I first deleted the app from my Apple TV and reinstalled it (just in case). Now I notice that when I do not have the companion app connected and only use the Apple TV all seems relatively well. But when I connect the companion app my previous stated issue reoccurs. As well, when the companion app is connected (using IPhone 12) and I’m using the Apple TV for Zwift, the trainer difficulty no longer shows up in the settings.

The result is no companion app and it feels normal, companion app connected and no matter the surface or incline/decline in the game the trainer feels like it’s fighting me.

Am I missing something?

Thank you for your time,

Ok, good news that you’re intentionally setting Trainer Difficulty to maximum.

The “Power Estimation Mode” option in the Settings menu is expected when using non-smart trainers, which rely on a wheel speed sensor to estimate your power output. The Zwift Hub is a smart trainer that has an inbuilt power meter, so you shouldn’t be seeing Power Estimation mode.

This would also explain why the resistance of your controllable trainer feels out of control. :wink:

Bottom line: As I noted before, the Settings menu is context-aware, and it’s seeing neither the Power meter signal, nor the Controllable signal. Check your pairing sequence. It should be:

  1. First; pair to Power signal using the Companion app as a bridge.
  2. Click Controllable and allow 10-15 seconds for the controllable signal to appear. It won’t start broadcasting until the power meter signal has completed pairing. This delay is normal when pairing over Bluetooth.
  3. Finally, pair Cadence, heart rate monitor, or steering device if you use those.

Lastly: make sure that your trainer’s Bluetooth signals are not already paired to something else: another instance of Zwift game app running on a laptop, tablet, or smartphone / bike computer head unit / some other app.