Zwift forcing a low cadence

Set up a custom work out, get to the intervals, trying to meet the power target and zwift keeps upping the resistance. Usually when power is too high, zwift lowers resistance so that cadence stays up but power comes down. Instead zwift increased the resistance, and ground me to a halt! Trying to push 290 watts at 60rpm really isn’t a lot of fun! Weirdly, when my power was too low, zwift still increased resistance. So what am I supposed to do to get the cadence I want and meet my power goals? Surely it shouldn’t be a choice! Not the first time its happened either.

I’m using a BKOOL smart pro 2 turbo trainer, power and cadence is from Powertap p1 pedals. 

Have you tried changing the ‘Trainer Difficulty’ setting in Zwift?

No I haven’t.I don’t run into this problem often. As I understand it, lowering the trainer difficulty will also mean less gear changes and gradients won’t feel the same, though I’ve never tried it. I’d hope there is another solution but I’ll try that if there is nothing better.

This is an intermittent problem Declan?

Yeah it seems to be. It lasts the duration of the session, and seems to stay if I restart too. Its a problem when I try to do an FTP test too as the resistance forces me into an uncomfortably slow cadence.

Could there be any devices around your setup messing around with the signal?

As an aside, I had some signal problems when the batteries in my P1 pedals ran low.