Zwift file upload has wrong time


(Bavo Vandermosten) #1

Hello,

When uploading my .fit files to Strava (either automatically or manual) the time isn’t correct.

I did a session today at around 7PM but after uploading it to Strava ot says I started at 9AM. My sister uses the same laptop and she doesn’t have this issue. I already relinked my Zwift to Strava but it doesn’t seem to help.

Is there a way to solve this issue?

Kind regards


(Ash Daughtrey) #2

I’m also having the same problem, doing rides in the evening but once uploaded to strava it says I’ve ridden in the middle of the night am. Very frustrating as there doesn’t seem to be a way to manually corrected the time on zwift.


(Steve Ellis) #3

Your Strava settings may be responsible. Check your profile at https://www.strava.com/settings/profile to verify that your Location is set to the correct time zone.


(_ MapsRider) #4

WTF!!! ayyy admin fix this f…kin lug with time zone,  I’m not training a 3am and don’t want spend my free time for fix date manual.  just make option TIME ZONE


(Suzanne Ferris) #5

The problem is with strava not zwift. The link above will help fix. Basically log in to strava and deselect and then save your time zone. Worked for me


(Kimberly Frankel) #6

You have to go on your computer and login into Strava. Go to settings and then within your profile scroll down to location. Mine originally had grayed out America/Los Angeles beneath what I had originally entered so I tapped on the pencil to edit. I entered America/Maryland and was able to get it to update to the correct time zone (eastern time zone)