Zwift exiting Fullscreen on Win7

I run Zwift fullscreen on a Win7 64bit system.

When Zwift is running, sometimes another program calls for attention (for example, the virus scanner has downloaded an update), causing this program to be displayed, Zwift keeps running in the background but the window is no longer visible. With Alt-Tab I can get Zwift to be displayed again, but still, this is very frustrating, especially in a race.

Can I / How do I change my Windows settings such that when Zwift is running fullscreen, I can prevent Zwift from going to the background?



I had something similar the other day when I had my phone plugged into my Win 7 computer to charge and I rebooted the phone. Zwift then reduced Zwift to an icon.

Check your anti-virus settings. Norton for example has a silent mode where you can disable it doing things for a specified length of time.

I get best performance from a maximized window. I can still use the volume control while riding and no issues with minimizing Zwift. For me, full screen has tiny surges (other riders).

@Nigel, I’ve had several applications taking me out of Fullscreen. If possible, I was hoping to “prioritize” Zwift over the other applications.

What has helped so far is powering up my laptop at least 10 minutes before starting Zwift, most applications wanting to download/update stuff do their checks usually after booting up. Still, it’s not a final solution.

@Cary, I get no surges while running fullscreen, I think it looks best that way on my 42" TV. Volume controls are on my wireless keyboard.