Zwift doesn't work on Samsung S6 lite

Merry Christmas All!

Annoying holiday issue. Unable to connect my Tacx Neo2 to a Samsung S6 lite via bt. The tablet recognizes the Neo in the bt settings but doesn’t show the trainer in the zwift App. The only possible connection is my Power2max via Ant+.

Any recommendations?

Make sure you only pair the trainer via the Zwift app on the phone, and that it is not paired via the BT settings on the phone.

The S6 lite is a tablet, not a smartphone. Bt isn’t connected in advance.

Hi i have the samsung s6 and had to ensure that when using it the following was applied.

  1. No other bluetooth devices being used at same time
  2. ensure the Tacx app is disabled or deleted when using zwift
    3 . make sure your zwift updates are current
    never had a problem since

No chance to get the zwift App running on S6 lite. Connection via bt or build in ANT+ impossible.
Now I’m using my old Xiaomi Mi Mix 2 phone, no problems at all.
Definitely a software problem.

2 Likes

Yep, same here. I just bought the Samsung S6 lite and can’t for the life of me pair it with Zwift. Anyone have luck doing this? I have no problems with my iPad. Go figure.

The same here to. Trouble connecting either with bluetooth or ANT+ TACX antenna to tacx Neo!
It connects for seconds only each time and then looses connection with neo…

Oh. Same issue. Any solutions for this??

I found the fix in another post in this forum, see below-

You must allow Zwift to have Locations permissions or Bluetooth doesn’t work. This is true for Android and iOS.

Go to Android Settings > Apps > Zwift > Permissions > Locations .
Give Zwift permissions.

Why? Android lumps GPS and Bluetooth radio functionality under the Locations setting. Zwift doesn’t need or use the GPS radio - it does need access to the Bluetooth radio so it can find your Bluetooth trainer.