Zwift crashing between 5-25 mins of every initial session

I am running an old AMD Phenom II x4 PC with a Nvidia Geforce 950 GTX and 16Gb ram with Win 10 64bit.

PC is only used mainly for Zwift and on the very odd occasion Tacx TTS4 RLV’s.

I’ve had the PC tested and its running absolutely fine, except with Zwift. I run Zzwift the first time and everything on screen freezes between 5-25 mins including the mouse. Ctrl+Alt+Del doesn’t even work, I have to switch off at the mains and restart. Upon restarting and opening Zwift, everything runs perfectly for sessions up to 2hrs 30 mins.

I’ve deleted Nvidia Geforce experience and rolled back the driver and it’s not made any difference.

I just don’t understand what it causing the initial fail. Can anyone shed any light on the matter? Is it a conflict between Zwift and win10?

Thanks in advance.

  • could be the Ram either of your graphics card or your mainboard
  • could be CPU getting to warm
  • could be the fans not working at 100 % forcing your system to shut down
  • could be solution is set to high (try playing around with 720p or lower)

The cpu temp doesn’t go above 48 degrees, it’s got new thermal paste on and the heatsink has been cleaned, checked with Speccy.

All fans seem to be fine. The graphics card fans only kick in when the temp on the card rises to levels which require cooling.

Resolution has only just been upgraded to 1080. It was 720 before and was crashing with the same regularity…

Not sure what else to try apart from downgrading back to win 7 to see if that’s more stable.

i guess check the rams than

How do I check the rams, and could they cause the crashes?

Memtest86. But chances are it’s just Zwift overwhelming your system. It’s got noticeably worse in recent months.

When one of the RAMs is broke i’m pretty sure it is causing the crash.
you can do it manually or using a certain tool (like Windows Memory Diagnostic inbuild Win10) to check your ram kits (or the one @Dave_Higgins1 posted).
manually just open your tower check how many rams you have (1x1, 2x2, 4x4) if you have just one i would go with a software tool.

if you have 2 or 4 remove all but one and check (your ram will be either 4 or 8 gb) if zwift is running with the lowest resolution first because as you said 720 and 1080 both causing the crash in the same time span.

I have two ram modules in configuration of 1x 8gb + 1x 8gb.

Total memory slots on motherboard is 4.

Type is DDR3, Dual Channel, DRAM Frequency 665.2MHz, CAS# Latency 9 clocks, RAS to CAS Delay 9 clocks, RAS# Precharge 9 clocks, Cycle Time 24 clocks, Bank Cycle Time 33 clocks, Command Rate 1T.

Memory Usage 15%, Total Physical Memory 16gb, Available Physical 14gb.

I ran the Windows Memory Diagnostic App and it reported no problems. Tried the Memtest86 and booted from usb but system just sat in black screen with flashing cursor.