Zwift crashes after pairing (OS X + TACX NEO)


I updated the firmware on my Neo and also updated Zwift today, and now Zwift hangs after pairing when I hit the “OK” button. Also it hangs when I hit the “SKIP” button. However, if I press “Just watch” it works fine.

I have reinstalled Zwift from scratch and tried it on two computers running OS X 10.11.4, same problem on both.

When I hit the “SKIP” button the log keep saying:

[21:20:10] NETCLIENT:Connecting to game server node []
[21:20:20] NETCLIENT:Connection timeout [10]


And when I try to pair the Neo the log says:

[21:23:48] ANT : Rx Fail on channel 1
[21:23:51] FE-C 240 received
[21:23:51] FE-C 251 received
[21:23:52] ANT : Rx Fail on channel 1
[21:23:56] ANT : Rx Fail on channel 1
[21:23:56] ANT : Rx Fail on channel 1
[21:23:59] ANT : Rx Fail on channel 1
[21:23:59] ANT : dID 1117519 SW Revision 1280 SerialNum 3407
[21:24:00] NETCLIENT:Connection timeout [10]
[21:24:02] ANT : Rx Fail on channel 1
[21:24:03] NETCLIENT:Reconnection requested
[21:24:03] NETCLIENT:Connecting to game server node []
[21:24:03] ANT : Rx Fail on channel 1
[21:24:03] ANT : Rx Fail on channel 1

I have never had any problems before today with Zwift or the Neo, so I’m wondering if it is the new Zwift update or the firmware of the Neo, or a combination. Have you seen this issue?

Thanks in advance!

Hi Toni, sorry for the trouble.  Since you can reproduce it can you try to get it to happen again?  When it crashes click “Report” and copy all the text OSX shows you into here or a support ticket?  That’ll really give us some details as to what is going on.  With that info I can possibly track it down today and have it sorted within the next 24 hours assuming it’s something on our end.

Thanks for the quick answer!

The problem is that it doesn’t crash, it just hangs and I have to force quit the application. So I don’t get any “Report” option, is there another way to get you some more information?

Double posting as I’m not sure which thread is more relevant: 

The same thing is happening to me, Jon, on both a Windows 10 laptop and a Windows 8.1 desktop (with entirely different specs, same Internet connection). My husband’s Windows 8.1 desktop with the same video card as mine and the same Internet connection doesn’t seem to have a problem.

“Just watch” works, but the “Back/Menu” button brings up the same problem when I try to hit “Pair” or “Skip.” I reinstalled the launcher, rebooted the computer, and the problem still existed. I uninstalled Zwift on my desktop computer and am in the process of trying to re-install it, but it’s stuck on “updating” and won’t seem to go anywhere, even when I closed out of the Zwift process in the Task Manager and tried again. I’ll submit a ticket with the log file if I can’t get it to work soon.

I would say maybe it’s a Tacx FE-C trainer issue, as I’m pairing a Tacx Vortex Smart as a controllable trainer, but it happens on my laptop even with no ANT+ dongle and trying to hit “Skip” instead of “Pair.”

Hey guys. It’s definitely not Tacx related as I’m having the same exact problem but have a Wahoo Kickr. However it’ll hang no matter if I have devices paired or not.

I submitted a ticket a few days ago and was directed to uninstall via the “Library>Application Support” method. Unfortunately it didn’t work.

I’ve since updated my OSX to the latest version with no luck either. I’ve probably uninstalled/reinstalled 3-4 times trying different things like rebooting before and after, making sure all Zwift directories are erased and nothing has worked. I’m pretty stumped and am just hoping they release an update that fixes the issue.

Please post back if you find a solution.

Have you tried again today, Bill? It suddenly started working again for me.

The last time I tried was last night. I’ll give it another go when I get home from work. Fingers crossed.

Same here, got home from work, made no changes. I have not even restarted the computer since the last try and now everything works fine. Must have been something on the backend side.

Just tried it and mine is back to working as well. Thanks for the info.

I am having the same issue can watch but not do anything else, it hangs indefinitely once hitting OK, running Windows 10 and updated to the latest version and have been unable to use it since =(.  I also happened to subscribe after my free trial ended and now it doesn’t work, talk about a let down. Hopefully they figure this out soon since obviously their update broke something after pairing devices. I have a Stages power/cadence meter and Garmin heart rate strap if that helps. 

I’m also getting the same problem since the last software update. Screen hangs and I have to force quit the app

I’m getting the exact same error. I can watch and even go back to “me” where I’m just parked on the sidelines, no HR, no cadence, no power (wahoo kickr). If I try to pair it from the menu screen, instant crash. Also get the crash from the initial screen if I don’t click on just watch. 

Interestingly I also can’t get the mobile Zwift app to work either, it also hangs up on the first screen with pairing and never progresses. Was all working fine on May 4th but nothing since then. This makes me think it’s on Zwift’s end with their software and maybe in the user profile to pairing, since I can’t get either device to work. 

Keith (kwalter827)


We would like to look in to this further- I have raised it to a support ticket to help sort the problem out.