Zwift Companion "Update Required" message [April 2022] [Android] [SOLVED]

@wes android companion broken now and neo road feel issues.

Noticed same. Opening companion app on android, get the need to update splash, but opening the Google store link only option is to open or install. App version says it’s the latest but date of 31st March

@Paul_Cooper_SZR @David_Sleator
Thanks for the report. I’m seeing the issue as well, and the team is aware.

For clarity: when updating the Companion app, I see this screen that I can’t get beyond:

I have a Google Pixel 4A. Today went opening these with companion, it tells me that I need to update the app.

But I have auto updates turned on in Google Play.

I tried updating the app anyway, and there is no update.

So I uninstalled it, and reinstalled it. But it makes no difference, it still wants me to update the app.

I would be grateful for any ideas on how I should proceed.

Same here … well thats going to hamper riding and pairing sensors …

Seeing the same thing on Android. Uninstalled and reinstalled the app and still getting the message that my app is out of date and I need to update. Can’t use companion app at all.

Is there anything you can do, as its impossible to ride in a race - part of a series - when you use companion app for pairing sensors and the app is bricked like this.
Several weeks of effort in the series could be out the window .

Which would be very annoying!!

mine is working now

@Mike_Rowe1
Yes, we made a change moments ago that fixed this.

If you continue to have issues updating the Android Companion app beyond the screen I posted upstream:

  1. Try purging the cache for the Play Store app. Do this in Android Settings > Apps > Google Play store > Storage & cache > Clear cache
  2. If that doesn’t do it - reboot your phone.
  3. Go back to the Play Store app and update / open the Companion app.
3 Likes

Endless loop taken to the app store, no update for companion available

1 Like

Uninstalling and redownloading solved this issue for me.

Same problem as mike continues ti ask me to update.

Hi Wes… Updated and says CA needs updating and sends me to play where there is no update. So CA is down which is a huge deal. I noticed someone else with the same issue in comments in Zwift riders on FB… Can you fix please?

(as comment above here too)

Sorry @shooj i was in an event.

Warns of android update, takes me to open or uninstall page. Uninstalled on both tablet and phone but locked in a loop. Open just advises me to update.

Luckily I’m leading in 24 hours 8 minutes so there may be time for a fix.

1 Like

Had to reboot my phone after the update, I’m back to normal.

1 Like

Can confirm clearing cache on Google play store worked for me, companion app working ok.
Cheers

1 Like

Up and running too after cache clear.

As for road feel in london i get as double thud every second on tarmac.

It is working for me now. Thank you so much!