Zwift Companion App Out of Date but is Latest Version

Went to open my companion app but get stuck on screen saying i need to update to the latest version. when i follow the link to the app store it says im at the latest version. please fix.

IOS 13.5.1 iphone 8
Zwift version 3.15.1

Exact same issue here on Android. Google Pixel 3, Android version 10.

1 Like

Same here. I even uninstalled and reinstalled from Google Play and its still doing the same thing.

Sort it out Zwift!!!

1 Like

Same issue here on iPad

Just got this error on iOS iPhone 11.

Exact same issue here, app keeps asking for an update, did it, keeps asking refusing to launch!

Hi

IOS 13.5.1 same issue with Zwift Companion App get message to up date but no up date available

Same issue. Please resolve ASAP Zwift.

Same issue. Worked this morning at approximately 7am PST. Not working at 9:45am PST.

Zwift knows of the issue and is working on it. I emailed them 30 minutes ago and they replied saying they will keep us posted via this link: https://status.zwift.com/

3 Likes

Same here. I tried deleting and reinstalling the app, no help. Tried rebooting iOS (also newest version), no help.

Same issue. Worked from 8-10 cdt today. Not working now reinstalled app. Still not working.

Zwift is aware and is investigating.

Im having the exact same problem,

Now reported as fixed… https://status.zwift.com/

Resolved - This incident has been resolved.
Jun 27, 17:01 UTC

Uh. Not fixed. At least on Android 10. Same Update -> Google Play -> launch and get Update screen - ad infinitum.

2 Likes

OK, on Android, at least, if you force quit the Companion app and relaunch, you can at last get it running without the dummy Update button.

Of course, Zwift does not provide the helpful tip, you have to figure it out for yourself.

QA department clearly not working on weekends and left an intern to push the update the production.

Brilliant! Thanks. Just tried this and it’s working now…

Hi, I had the same On screen message issue on iOS so I deleted the app but it continued, so then I updated my iOS software which took about an hour, then It worked. I thought that was the fix but maybe Zwift HQ had just fixed the bug in the time it took.

Companion app still not working for me.
Just tried deleting the app and downloading again and it works. Thanks!