Zwift Companion Syncing Issue

Hello,
I am new to Zwift, about 8 rides in. I am running zwift on my MacBook Pro with Ant+ connected to a wahoo kickr. I am running the companion app on my iPhone over Bluetooth on my WIFI network.
My problem is that the zwift companion app never stays in sync with zwift. Everything runs well for 10 mins or so and then the companion app winds up being 10 mins behind my actual time in zwift. The companion app will seem to lag and the time will then jump from 15:00 to 20:00 then back to 17:00 all in the span of 10 seconds of actual riding. Meanwhile my actual time on zwift is somewhere near 30 mins of riding at this point.
If I turn off the companion app and restart it will sync up for the first minute and then back to the example above with my time on the companion app all over the place and never in sync with my zwift ride.
I’ve tried resetting my WiFi network, reinstalling apps, switching from Bluetooth to the ant+ setup but am still having the same issues. I have also shut off cellular data and the iPhone companion app is strict on the WiFi as well.
Has anyone else had this issue? If so, please help with what I should do.

Thank you

  • Double check that your Companion app is updated.
  • Put your iPhone in Airplane mode.
  • Make sure it is on the same WiFi network as your laptop.
  • Force quit the Companion app after each use.

The Companion app does not use Bluetooth to connect to Zwift. In your case, running Zwift on your laptop, you can totally disable Bluetooth on your iPhone and it will not affect anything.

I have been using Zwift for over a year and recently been having this same issue. My Companion App is out of sync with the Zwift app on my Apple TV by minutes before too long. I cannot turn off bluetooth on my phone, either, because I have to pair my devices through my phone- AppleTV doesn’t have the capability to run that many devices on bluetooth.

I have the latest versions of both the Zwift application and the Companion App.

I am sorry to say that I haven’t found a fix. I think it is a new “feature”.

I had this “out of sync” time issue w/my Companion app once in the last month. I have only been using my laptop for Zwift these past few months. That said, it’s highly unlikely this issue is an Apple TV issue and more likely a Companion app or Zwift server side issue.

If you need to pair devices through the Companion app or need Bluetooth for wireless earbuds, etc., then leave Bluetooth on. Bluetooth is not the problem. However, if it’s not needed, turn it off. It’s one less source of noise per se.

The important thing w/the Companion app is to make sure it is not using mobile data and is on the same WiFi network as your AppleTV. Hence, the recommendation to put the phone in Airplane mode.

Hi Tom,
my iPhone has just received a Zwift update and I am also having problems.
The update happened 2 days ago and since then any Zwifters I follow or who
follow me are not separated into those on line and those offline. (This is whilst I am using it Zwifting.)
I’m pretty sure it is an app problem that has occurred since the latest update.
Last working version for me was 3.8.2 now I have problems with 3.9.0
Sorry I don’t have fix for you or me.
“Ride On”

Hmm. Thanks at least I’m not the only one experiencing this issue. I have tried all the “easy” fixes and suggestions above but am still running in to this issue each time.
The only thing that seems to help is resetting the router before use each time, but then, The companion app holds up fine for 20-30 mins before becoming out of sync and eventually being completely useless during the ride.
I’ve also tried the companion app on the iPad mini 4 that only has WiFi capabilities and the companion app has the same issue.
I’m hoping it’s a big or a server issue and could be fixed but I’m still not sure what I’d causing this problem.
Anyone else have anything similar going on between the companion app and zwift.

Thanks again.

Have you tried to put your wifi router to a static channel one with very little interference from other channels.

I have a router from my cable company. Any advice how to switch the channels of the devices? I wouldn’t know where to begin with that suggestion.

Hi Tom,

there are so many different routers, I would suggest asking you cable company.

It’s worth a shot. I know I can switch between 5ghz and the 2.4ghz. I am using the 2.4 because in other forums people were having issues with the 5ghz and the devices.
It’s a frustrating issue but luckily zwift itself runs fine and I’m still able to get my workout in, its just really difficult to interact and use power ups etc.
thanks for the advice.

It would be nice if Zwift could bring the Companion app functionality into Zwift. Like why do you have to have a $300.00 phone on your handle bar to only give a ride on when it can be done with a $30 keyboard or a $20 Bluetooth game controller.

1 Like

My next ride is tomorrow so I will try the suggestions everyone has made and see if it helps with the issue. I’ll also give the router another reset to see if it helps again. Hopefully I can ride for more than the first 10 minutes without the companion app going out of sync with the Bluetooth completely off. I’ll follow up again tomorrow after the ride to report.

1 Like

Well, I’m disappointed to say that the companion app was out of sync during tonight’s ride within 5 minutes of beginning. I noticed it was fine until I have my first “ride on” and then as the circle around me came up it went extremely slow and then the time was behind for the rest of my 75 minute ride. I even forced quit the companion app and rebooted and no luck, within a minute it was behind again.
This is with using the ant+ on my MacBook Pro, resetting the router before starting my ride, turning the iPhone to “airplane” mode and turning off Bluetooth on the phone. I also turned off the Bluetooth connection in the companion app.
I wish I knew what the cause of the issue is as it makes the experience less interactive with my fellow riders.
Any other suggestions or advice would be appreciated.
Thanks again for reading.

Is your iPhone updated to the latest iOS? There have been several updates to fix what seems like a million bugs in iOS 13. H3LL, there was one waiting for me this morning (13.2.3) :man_shrugging: Update your phone. Then, try force quitting all other apps (not that it should be necessary) and give it another go.

Yes, everything is updated with the Apple update from yesterday. I don’t think that should have an effect but I’ll try again on my next ride. I may try using the companion app on the iPad mini instead of the phone to see if it works on that device. The iPad mini only works on WiFi and I’ll turn the Bluetooth off on that too.
I still do not know what could be causing this to happen.

Still no success but I was able to log on to my provider and found a port management section for the router. So I have to set up a special command for zwift companion to function properly?

I finally had success with the companion app. I tried switching my MacBook Pro (running zwift with ant+) and my iPhone over to the 5ghz WiFi network in my house and everything worked perfect. No lag at all today between the companion app and zwift. Maybe it was too much interference on the 2.4 ghz side?
Just wanted to post what worked for me Incase anyone else is running in to this issue.
Thank you.

2 Likes

I have the same problem and your solution works for me too!
Thanks!