Zwift companion sees hardware, PC don't!

Hi,

Long story short, once in a while, i’m unable to ride on Zwift ! On my cellphone, Zwift companion sees the hardware (HRM and Tacx Flux 2 intelligent training) but the computer is still searching and not finding anything ! Can’t say if there’s a pattern after upgrades or something.

Typicaly, I reboot the PC + Cellphone + trainer, and sometimes it comes back, sometimes not. Today I had train with my garmin computer… so much fun (not). Laptop is in front of the home trainer, cellphone is on my stem. This is a reccuring problem and is very annoying since it takes a long time sometimes and kills the “vibe” like today ! Any clues on how to fix the problem ? Is it a Zwift issue or hardware issue ?

Hardware is:

  • Tacx Flux 2;
  • Garmin HRM;
  • Android Samsung S8, which has ANT+);
  • Lenovo E550 laptop on Windows 10;
  • Laptop and cell are on the same 5G Wifi.

Thank you so much !

Stephane

Hi Stephane,

It sounds like your Tacx signal is being diverted by another device (e.g. laptop, tablet) or workout app (e.g. Companion, Tacx). We have some steps you can take in our BLE and ANT+ Interference Troubleshooting Tips guide.

Make sure to turn off Bluetooth on all your devices (e.g. laptop), except your phone. Also, force close all workout apps on your phone, except Zwift.

To force close apps on Android, follow these steps:

  1. Open the Settings app.
  2. Select Apps.
  3. Select Companion, Tacx, etc.
  4. Select Force Stop.
  5. Repeat this step for all workout apps except Zwift.
  6. Start Zwift and try to ride.

If you’re still having issues, please reach out to our support.