Tacx Flow Trainer with Companion app unable to pair to Zwift

After a few weeks of my new Tacx smart trainer working mostly without issue, recently when I started it up Zwift wasn’t able to find my trainer in the Paired Devices menu. I am using the Companion App to pair. The LED on the trainer is blinking green, and I know the trainer is working properly, as I can still connect to the Garmin training app on my phone. (but, not to Zwift)

I’m running Zwift from the Zwift Launcher on my SurfaceBook (Windows 10) and the Companion App on Android. My trainer is the Tacx Flow smart trainer.

I’ve followed all of the troubleshooting steps, including resetting the companion app on my phone, updating FW of my trainer and of the Companion app, and verifying I am on the same WiFi network. Still, Zwift cannot find my trainer.

You mention you are using the Companion app to pair. Have you tried connecting directly to your SurfaceBook? Also, if using Bluetooth to connect, is it possible your trainer is still connected to the Garmin app on your phone? BT will only allow one app to be connected at a time.

Hi @Daniel_Galindo-Navar

Sorry to hear that you’ve run into trouble when using the Zwift Companion (ZC) app as a BLE bridge to pair your Tacx smart trainer to Zwift.

This is actually a known issue as we’ve received many reports of Zwifters unable to pair their devices when using the ZC BLE bridge on Android. You can find more information in the pinned Forums thread here.

Seems our developers are confident this will be resolved soon, so we appreciate your patience while we get it sorted out. Thanks!

Yes - I have tried the “Use Built-In Bluetooth” option on my PC, which doesn’t work.

I have made sure to force-close the Garmin app before opening the ZC. Looks like some other people have had this same problem, and they’re working on it!

1 Like

Hi I had the same issues
I re installed all of the apps and deleted the tacx APP
ensure that you are running only 1 bluetooth device when linked to the trainer to avoid conflict between devices and that should solve the issue