Trouble connecting with Tacx flow smart [SOLVED]

Hi, sorry if already posted, but see below. Little desperate after hours…

I’ve spent hours trying to couple my zwift on iphone se2 to my new tacx flow smart. I’ve read a lot of support and tried all tips, but it doesn’t work.

I’ve shut down other connections, even deleted some apps to be sure. Rebooted the tacx. Reinstalled zwift app. Still no connection found in my zwift app.

It is though quite clear that the app itself is connected to bluetooth and even to the tacx, because if I disable bluetooth connection in settings for the zwift app, it also disappears in my bluetooth connections screen. Even when closing zwift, it comes to tell me that bluetooth connections use power. So it seems like there is a connection, but it doesn’t show on my connection screen.

(I wanted to insert screen shots but it doesn’t work here)

What can I do more?

Hi @Youri_Segers welcome to Zwift forums.

Our Support Hub may have an important clue to chase down specific to some Tacx models including the Flow Smart.

Rather than pairing to the native Bluetooth receiver of the computer running the Zwift game app, you may have better luck by using the Companion app as a Bluetooth bridge. Some more information on the Companion app here:

Hi, thank you for your response. One day later it work by connecting zc app. Still not flawless, but it works and I can start training. Thanks!

1 Like