Zwift Companion - no Game mode on Pixel Slate / Chrome OS

I recently picked up a Pixel Slate tablet, specifically to run the Companion app while using Zwift. The Slate runs Chrome OS, and while the app installed and mostly works ok, the game mode has never worked while I’m Zwifting (it doesn’t even show up on the menu). I also have a Pixel 4 with Android and game mode works fine on that.

The phone, my laptop (Zwift app) and the Slate are all o\in the same subnet, on the same access point, on the same wifi band, and I’ve verified that they all at least have basic connectivity (via ping) to each other. Although got a pretty great deal on the tablet, the fact that I have no other use for it than the Companion app has me feeling a little bit of buyer’s remorse. So I’ve got two questions…

  1. Are there known issues with the Companion app on Chrome OS?

  2. Has anyone had success with the game mode screen on a device running Chrome OS?

Thanks!

-Josh

Hi Josh,
did you tried to contact Zwift`s technical support directly?

Hi Adam,

No not yet, I wanted to see if I could get some feedback from the community before I tie them up with another support ticket. :slight_smile:
-Josh.

1 Like

@Josh_Currier1 I have the exact same problem on my Pixel Slate! It’s so frustrating. Please do file a support request and report back here - I’ll do the same.

The Companion app works fine on my ancient 2014 Samsung tablet, but the version of Android on that is so old that the app seems to be stuck on an old version where half of Watopia isn’t even built yet. EDIT: actually I just managed to update it :slight_smile: But it’s very sluggish so I’d love to be able to use the Pixel Slate instead.

1 Like

I’ve submitted this to support, we’ll see what they say!

I did already - unfortunately so far they’ve only provided completely irrelevant advice as if the problem was related to connecting BLE sensors or to the wifi network, or to interference from microwaves (!) and that kind of thing :frowning:

Got a reply from Zwift:

Hi Adam,

Thanks for getting back to us!

After looking into this further, the main biggest issue here is the fact that the Pixel Slate uses ChromeOS. While you may be able to download the app on your Pixel Slate, ChromeOS is still not a supported OS for Zwift or the Zwift Companion. While there is the option to download it and some of the features work, this isn’t something we can support as ChromeOS is emulating an Android and doesn’t actually run the same. However, since you can get your old device to run the companion, we’d advise just using that in the meantime.

We hope this helps clear things up and if you have any other questions, please let us know!

I’ve replied back as follows:

Thanks for the reply Zachary. I appreciate that you have probably been informed that “ChromeOS is emulating an Android” by other folks at Zwift, but this is technically incorrect.

Chrome OS runs the full Android environment natively within a container on top of the Linux kernel. There is no emulation, or even any virtualization - please see the article I’ve quoted below for proof of this. Therefore even advanced features of Android apps such as talking to Bluetooth hardware work out of the box on Chromebooks. I have first-hand experience of this being true, since other Android apps on my Pixel Slate which use advanced features (e.g. MobileSheetsPro) work flawlessly.

So I repeat my request to have this issue escalated to your engineers for full analysis.

Please see this 2016 article https://arstechnica.com/gadgets/2016/05/the-play-store-comes-to-chrome-os-but-not-the-way-we-were-expecting/ which explains the technical architecture of how Android apps work on ChromeOS:

"The new model dumps the native-client based implementation for an unmodified copy of the Android Framework running in a container. Containers usually bundle an app up with all of its dependencies, like the runtime, libraries, binaries, and anything else the app needs to run. This allows the difference between application environments to be abstracted away. In this case, Google is putting the entire Android Framework into a container, all the way down to the Hardware Abstraction Layer.

It’s a lot like virtualization, but a virtual machine would sandbox the apps away from other apps and the rest of the OS. Containers let the Android apps access the underlying OS, which allows them to communicate with each other. Connectivity, storage, audio, touch, and all the other inputs and outputs get connected to Chrome OS, allowing Android to interact with the outside world."

This is my third attempt to get a technically valid response to the issue via their normal support channels. If I don’t get a decent response this time I’ll escalate via Twitter and any other communication channel I can think of.

Thanks Adam, It doesn’t sound like they have any intention of supporting ChromeOS. I kind of don’t blame them, since the Slate is the only tablet running that OS. I’ve ordered a Galaxy Tab A and the Slate is going on Ebay.

We’re not asking them to support ChromeOS though. We’re asking them to support an Android device which happens to also be a ChromeOS device. Furthermore, I’m pretty confident that the lack of Game mode on Pixel Slate is not a conscious decision on their part not to support that device, but rather simply an accidental bug which could probably be easily fixed.

That’s not true - there are several other Chromebooks out there which operate in tablet mode, e.g. https://www.forbes.com/sites/nickkurczewski/2019/08/28/the-best-2-in-1-chromebooks-for-2019/

Next instalment:

Hi Adam,

Thanks for the reply, and feedback.

I’m definitely sorry to hear you’ve been unable to get the Companion app, to go to game mode on your Google phone. Just to clarify, are you requesting that our dev team review the possibility of supporting Chrome OS on all devices, or just tablets and mobile devices in general?

Thanks!

and my reply:

Hi Aaron, thanks for the reply. Firstly just to clarify in case there is any confusion, my Pixel Slate is not a Google phone, it’s a tablet. And the problem is that the “Game” entry never even appears in the menu on the left-hand side, so I’m unable to even try to switch to Game mode.

Regarding your question about what I’m asking for, it’s actually neither of the things you described. I’m requesting that the dev team analyse the bug in the Companion app which prevents it from working on this Android device. As explained in my previous message, this device is capable of running all Android apps natively, and indeed I’m running about 50 other Android apps on it with no issues. Unlike in the main Zwift game app itself, switching into Game mode in the Companion app only needs to show a map and some statistics, so it doesn’t even need to do anything complicated relating to the device’s hardware. That is why I believe this is a simple bug and nothing to do with hardware support.

Thanks,
Adam