Zwift Companion & Ethernet


Been finishing up my new pain cave but ran into a small issue. Moved from a laptop on wifi (which was on the same wifi as my phone) to a wired internet connection to a PC. Now the companion app does not pair with the game as the Wifi is on a mesh network which is different than the router the ethernet is plugged into (mesh network is plugged into the router as well). I reckon it has do with how network is setup but any suggestions? Probably not the first one with issue but quick search only talked being on same network (which for me would be mesh). While I could live without companion app it was easy to bin the occasional crappy powerup with it.


It has to be on the same subnet. Mesh networks often create their own. You’d need to look into the settings of the mesh devices to see if this can be disabled. You’re looking for AP mode.

1 Like

Thanks! Will have a look but not hopeful. Might have to resort to moving one unit in between ethernet cable and PC to the hopefully be on same in an easy manner.

Here’s an example: How to set up Deco to work in Access Point mode | TP-Link

1 Like

Thanks @Dave_ZPCMR ! Will try that hopefully tonight.

1 Like

Unfortunately did not work. Whole network stopped working. Probably has to do with setup of router before the wifi mesh network but struggling to get it back online (Decos suck as it wants to do everything through app but due to this issue it couldn’t find my network anymore) so will stop playing around now. Might opt for lazy solution to put a deco between ethernet cable and Zwift PC and see if that works.

Ideally one did not need to be on same network but just online but alas.

Thanks for help Dave.

Will sound like spam now but…

Coincidentally when I made the change the internet as a whole dropped out at the source. Seemingly unrelated to this but did not realize that at the time! Realized it later when internet dropped out more often.

Long story short: Tried access point route again. Internet worked but companion app still does not pair with the game unfortunately! Not sure if putting deco in middle would resolve this but might give it a try in future.