Zwift Companion Apple

Hi, I wondered if anyone could help me please. The companion app on my Apple device has not worked for 1week now. I’ve tried uninstalling the app, restarting my phone but still no luck. I can’t use messaging facility which I find frustrating when leading rides as my shortcuts can’t be used in game on the MacBook. Has anyone got any suggestions as to how I can resolve this? I can’t see any posts relating to my issue, TIA :wink:

Definitely odd, did this start after the companion app update recently? And is your phone still compatible with the companion app? Also, is it just the in game messaging function that doesn’t work, or is it the entire app(even when not riding).

Hi, Yes started after a companion update last week. The app stays in the main page even during a ride so it doesn’t enter the group messaging function. Phone is compatible too. It’s a strange one, hopefully it will sort itself out.

Something that has happened to me in the past is having the companion app open on another device, that will sometimes stop it from pairing to the game. The two devices are on the same network, correct?(if the phone is on cellular data or another wifi source, it will not pair to the game). Other than that, there is not much I can think of… If the issue persists you could also open a support ticket at There are also other forum members that may know a possible solution.

1 Like

Thank you, I really appreciate your help and thank you for the link too :blush:

Sounds like it’s not on the same wifi network as your MacBook. Put the device into Airplane Mode and check the wifi network: Settings > Wi-Fi


I’ve had this issue where I’ve checked event info on ZC on one iDevice before a ride, and then tried to use my main iPhone for ZC when I’m zwifting, to discover that the main one won’t pair because another is paired. If only there was some way in ZC for force an unpairing of other devices.

Thank you, I’ll try that. I was able to have a little use of the app this morning with the ability to message for about 5 mins, then the app seemed to refresh/kick me out. I’ll log a ticket with Zwift :blush:

Oh that doesn’t sound good. Luckily I only use my phone for all things, then when I ride my MacBook has Zwift and I use my phone for chat etc. I’m going to log a ticket as I’ve exhausted all options :blush:

If putting your phone in Airplane mode didn’t fix it, then try rebooting your router.

It sounds like different wifi network to me also. I have a 2.8 and 5 g network. Every once in a while my phone will connect to 2.8. Then the game just stays on home screen like she says hers does.

1 Like

Thank you for reply. This morning we restarted everything included the WiFi, router, devices, MacBook and it worked. All of your suggestions really helped and got the brain ticking. Thank you so much :wink:


This is a great topic, the 5ghz versus 2.4ghz thing is what’s occurring for me as well. I cannot see how to force my router to stay on 5ghz.

I have both 5GHz and 2.4GHz networks from the same wireless access point. I gave them different SSIDs/names (e.g., fastNet, slowNet). Then I only configure one SSID on my devices so there is no way they will end up on the wrong network.

2.4: televisions, baby monitor cam, guests
5: appleTV, iPhones, laptops

edit: if you don’t need 2.4GHz, then disable it.

1 Like